New model

So… i’m interested in the new model that Anova is promoting ( the 1000 watt unit)… is it strictly wifi or does it have both like the 900 watt model did (wifi & bluetooth)
Just really curious…

Just took a look at the specs and I see only WiFi. No Bluetooth mentioned.

Should have included link…sorry…

I didn’t see it either… Was hoping for an answer from anova… It would be interesting to see if they dropped the dual feature

You’ll be extremely lucky if you get an official response from Anova here. It appears that the official forum has been abandoned.

I’ve absent from here for awhile due to Life and other circumstances but is @AlyssaWOAH not a part of the community anymore?

No. Alyssa left the company and her role as community manager hasn’t been refilled.

That explains a lot…

I recently purchased the new model, a third one because my other two just stopped working. The new model is much easier to adjust the temperature and timing but it does not work with Bluetooth and I can only do the settings manually, it just won’t connect to wifi to allow me to make any temperature/ timing settings from my phone. Extremely disappointed as the new model is much more expensive for a manually controlled device. Maybe my wifi router is not compatible with the new device but as I’m not a tech-savvy person, I have no way of knowing if its actually my router that is at fault or if I’m doing something wrong. The wifi-section of the instruction guide is just too brief and offers no troubleshooting advice.

Sous vide is a great method of cooking but the Anova just keeps disappointing me with its connectivity

Hmmm… So, you had bought two Anova’s already that stopped working. And then you bought a third one? That’s what I’d call persistence. I usually give a manufacturer at most one second chance…

I suggest to buy a manually controlled one next time. Or control your Anova manually, which is the only way to use it anyway, because all other options are permanently broken.

Yes the first one was Bluetooth only which stopped working after a few months and I received a replacement from them which was wifi and Bluetooth. It worked well and I could control it from my iPhone. I stopped using it for a while and when I tried to use it again it just kept heating up and won’t stop so I dare not use it anymore. The new one i can only control it manually and can’t connect to my phone at all. The beep of the new model is soft I can hardly hear it if I’m not standing next to it.

Check your wifi password. Another user had problems with their phone and circulator not connecting. He saw in a troubleshooting page that if your password has a space in it, it can cause the connectivity problem. His wifi password had a space, he changed it and his problem was solved. That didn’t work for me. I have the Nano, and it still won’t connect. I’ve seen on these forums that a lot of users have a connection problem…

Hi there!
I made a video for the unboxing of the new Precision Cooker :slight_smile:
Can´t wait to make some… Brisket!