Couple of small improvements I'd like to see.

Just got my WiFi unit to replace a Sous Vide Supreme unit that died, and initial appearance is good, but there are a few details it would be nice to see improved.

  1. The startup connection sequence: creating the account is fine, but you lowercase the email address for storage (sensible) but then compare the user input exactly as typed. So when I create the account using Paul.Griffin@… and try to log in it fails until I try paul.griffin@… annoying, and not obvious unless you are reasonably computer literate.

  2. The time delay between initial account setup and the verification email is far too slow - 40 minutes! And that’s with me checking every sixty seconds if I had new emails…

  3. The mains lead is too short - 70cm? It needs to be longer, as most of that length is immediately taken up by the vessel you immerse it into. Please, 1.5m or 2.0m is a lot more friendly!

  4. On my phone (Moto G) the app doesn’t display numbers correctly - when setting the temperature they overlap each other and the bottom third of each digit is lost. This makes the decimal point a guess! :laugh:

  5. I can’t even set up a BlueStacks Android emulator to work with your App on my PC - it installs, but won’t connect because it doesn’t have “real” bluetooth so I can’t find a way to get directly to the Wifi interface with the running Anova except on my phone. A web based solution would obviously be better, but anything which lets me access the device via my PC instead of digging out the phone would be good.

Other than that, it heats fast, and looks good!

While I certainly wouldn’t object to a longer power cord myself, I’m not sure that I understand this:

In what way is the cord “taken up by the vessel”?

Mount the circulator at one end of the tank, so you don’t have to reach across the water to use it, and most of the mains lead is used up before you get to the back where the mains sockets might be! :laugh:

Mounting the Anova at the far end of the container makes more sense to me, because you can see the display much easier that way. And given the size of most containers used for sous vide, It doesn’t seem to be very far of a reach across the width of the container.

I think the general consensus on this forum is to ditch the app and set the temperature manually, then use a separate timer to time the cook. That way, you don’t have to worry about the cooker’s persistent beeping after the cook time has elapsed. It’s quite sad, because the app would greatly enhance convenience if done better.

For the sort power cord on the APS, just get a short extension cord rated for appliances or air conditioners.

That would be a pity, because the app is one of the USP’s for the device, and with a little attention could be very handy - particularly if there was a PC / web version available.
And my counter is deep, but getting crowded so “lengthways” makes more sense in this application - I’ll have to get a 1 gang extension, but it shouldn’t really be necessary. Mind you, when I bought the Sous Vide Supreme this replaces I had to throw the supplied mains lead away as the IEC320 connector was undersize and kept falling out of the back of the unit … :laugh:
I guess you can’t win!

I’m still a bit lost regarding what the issue is here, and exactly where it is you’re trying to mount your APC that’s causing it to be so far from an outlet. Here’s how I mount mine. It’s close to the wall outlet, and no reaching across water for anything:

(Ignore the cutting board and foil…this is an old pic.)

It’s a little complicated, partly because this is a 200 year old “river stone” cottage - which means that drilling any holes needs diamond cutting equipment, and partly because of the organisation of the kitchen.
It’s U shaped, with most of the mains points on the left U - which is only two foot wide, and has the cupboards above it. I don’t really want to risk steaming my dry goods, so that side is out.
The middle of the U is the sink and drainer, so that leaves the right U - which is 3 foot wide, but only accessible from the kitchen side. You can ask my wife why there needs to be a sofa on the other side of the worktop, but I didn’t understand the answer when I tried that!
What I’ve decided to to is dual purpose my deep fat fryer - I have an industrial one which holds 8L of oil, so even with the Anova in there, there is plenty of space for circulation and food (I’m used to cooking whole beef and lamb joints in the old unit, so I need the capacity).
At the bottom of the right side U is the dining room window, so it can’t go that end - deep fat fryers plus curtains are a bad idea. And it can’t go right at the other end because I don’t want to burn people walking by and it’s other role as a deep fat fryer means high temps.So basically, it has to go in the middle-ish. And that means the Anova has to be on the side nearest the user - my wife is fairly short, so if I put it too far back it’ll be hard for her to reach. (And given that she hates new things, I need this as easy for her as possible or she’ll find an excuse for me to do all the cooking :laughing:)

But that means that before the plug even starts to get near the socket, it has to travel the whole length of the fryer and that means there isn’t a whole lot of flex left! It’s not a serious problem - I can buy a 1 gang extension - but such a short lead does look silly and “cheatskate” on a device which otherwise looks like well thought out, quality kit. 1.5M or 2M would be a lot more reasonable, at not a lot of extra cost.

It works though - I tried it with a couple of rump steaks last night! :thumbsup:

So … thought I’d show you what I have so far:


(did that image show?)
The body is my deep fat fryer, with a 1/2 Gastronorm polycarbonate lid upside down (so the unit rests on the lid, rather than the metal base, which makes a “drumming” sound). I’ll add a wooden breadboard epoxied to the lid to locate it using those two mounting pegs when I break out the router and saw, probably tomorrow.
That should all mean that I can convert back to “fry mode” with an empty, dry and refill with oil, then back to “Sous vide” mode after I’ve emptied and cleaned the oil out - which I have to do after each frying session anyway.

Images added - hopefully visible, but that was “manual mode” - how are you supposed to add them, please?

And I can only add one image at a time… :Sigh:

And the other side:


Hopefully this shows how much cable there is left at the back of the unit! :smile: