New Anova App Horrible

Anova pushed out a new app for thier cookers last week and when I saw it I thought “are they kidding”, you actually lose functionality and reliability. I’m running on Android and with the old app it was rock solid connected, no issues, this one drops all the time and sometimes won’t connect at all without unplugging the Anova. The old app never did that. Not only that it inconsistently sends information to the cooker, for example, a temperature, but won’t send the time. Again, old app never did that. As others have said too, now the cooker occasionally flashes these random temperatures for no apparent reason. Lastly, and I’m super pissed about this one, it no longer shows the state of the preheating, the status indicator for the cook and where’s my message that the cook is complete. I’m a supervisor engineer, I would fire the person who pushed out this garbage buggy code…this severely impacts the Anova brand. Listen carefully software development team, the old app was much better, if you want to improve something, revert back to that one. If this is not fixed soon, I’m going to update my review of the Anova Precision Cooker on Amazon.

4 Likes

Can’t disagree. Can’t get past the ‘reconnecting’ screen on the new app on my old Samsung Note 3. Just further confirms my notion that the connectivity of the Anova is not much more than advertising bamf. I stopped using the app long ago, so it doesn’t really bother me.

But, I would suggest you give your feedback direct to Anova support. The forum is only populated by users, so there is nothing that we can do other than commiserate with you.

The app is terrible. Drop outs. Laggy. Need to reinstall several times. I’ve destroyed some eggs this morning and now trying scrambled. If the app fails again I’m having an Anova-sledgehammer session and will buy a competitor.

You do not need the app to use the Anova. The app is really not of much benefit once you’re experienced in use of the unit.

The Anova has controls on the head of the unit. Use these to set your temperature. For something time critical, like eggs, use a standalone timer. For other things you don’t even need that.

Awful app,that often freezes

As an iPhone X user I have to agree that the latest iteration of the app is appalling. Yes, I know Ember, that the Anova can be operated without the app, however, I’ve become accustomed to using the app to let me see the status of the cook etc and cannot understand how such a bloody awful revision was allowed to be released. I was seriously considering treating myself to the New Anova Precision Cooker - now I’m having second thoughts. Hopefully, someone from Anova reads these complaints and comes up with a plausble explanation together with an assurance that the matter will be dealt with in a professional manner.

The updated app certainly seems to enjoy the same wifi connectivity issues that the prior rev did (not sure when Anova broke it).

Current version of the iOS app is reporting as 3.0.0.

Running it on iPhone X running the iOS 13.3 public beta 1 (build 17A5821e).

Some feedback on the app:
The “Join Network” button isn’t functional when the keyboard is displayed - what’s the point of moving the button up if you can’t use it until the keyboard is absent?
The “Try Again” button when the wifi connection isn’t successful (4 attempts with this latest app - no luck) - the button appears to do nothing. No change in the screen, just the button momentarily changes to white when clicked - no other progress indicator on the screen (one would think it would go back to the connecting whirling dervish of doom).

Something else - though you now no longer appear to state so in any of the wifi connection dialogs, I’m pretty sure the app still has the issue that it will stay in “connecting” mode forever if you allow your screen to go dark / task switch out of the app (pretty sure you didn’t fix that yet).

New app is shit, connection troubles, not showing heating time and failing to deliver cooking time, terrible layout. Completely useless

I agree. I’ve posted on this forum as well as posted questions on their Facebook page and haven’t heard from the company. I don’t know if it’s ignorance or apathy but I loath being ignored. Not even a peep acknowledging the problem nor have they indicated that they plan to fix it. I’m probably going to purchase a Joules from Amazon if I don’t hear something soon.

Just remember, if the app doesn’t work with a Joule you can’t use the device at all. It has no control on the unit.

I don’t care about the Joule, I have two of these Anova Precision Cookers and I used the old app all the time, no issues. Now I can’t turn on my dinner at work and it’s ready when I get home because this POS app can’t find the Anova. Too say I’m furious would be an understatement, I’m livid that Anova dropped this garbage software without any notice, I would have turned off auto-update…

Hey Island Chef, one of the software engineers from Anova has been in contact with me, I’m an engineer too, just not a software engineer. I have been literally screaming at them since they dropped this crappy software on all of us. The guy gave me some things to try, I followed to the letter twice, no cigar, the app was still belly up searching for the Anova when I’m standing right in front of it. :neutral_face:
I liked the old app, the connectivity was rock solid for me and I’ve been starting dinner from work for over a year with it.
IMPORTANT NOTE:. The Anova engineer told me that they are about to push out an update to this app within days…so he said.
Last point, if you really want to complain directly to Anova, here in the forum is not the place.
Go to your profile in the Anova app and provide feedback to the app, everyone should be screaming at them like me from that place. :blush:

4 Likes

Remember that Anova has been acquired by Electrolux since 2017… so this crappy software is not surprising me, they are used to manufacture dishwashers not software

How to put temperature 54,4 •C if there is no possibility to put - dot…

Hmm. If that’s sending to the feedback@anovaculinary.com address, then it may not actually be monitored (it wasn’t for awhile).

As I’ve said here several times before: the only way to use the Anova (old app or new) is to not use the app. Plug the thing in, dial the temperature, press start when you want it to start, and press stop when you want it to stop. Problem solved.

All the people here who are complaining about the app are complaining (rightly) that the app is crap. But what they are missing is that no app should be necessary. Why on earth would I want to use my phone to cook?

Can I control my oven with an app? No. Can I control my cook top with an app? No. Can I control my toaster with an app? No. My microwave, fridge, freezer, coffee maker? No. So, where is the problem?

God help all the poor souls whose phone battery runs out at the wrong moment. Everyone will have to starve then, right?

The whole connectivity thing has been a solution in search of a problem all along.

3 Likes

Congratulations. You’re now experiencing the sames issues I’ve had (and others) with the app since I first bought this thing over a year ago (https://community.anovaculinary.com/t/whats-the-status-of-firmware-upgrades-for-wifi-issue/15836/12). They said a fix was coming, but it was just crickets after that.

At the end of the day, you really don’t need the app - the Anova works great on its own. But not happy about paying extra for wireless and bluetooth features that never worked.

My only problem is the loss of the ability to adjust temp and time manually. I am still figuing out my settings for different meats and so having to create a new recipe just sucks.I am really angry at this so called improved version.

1 Like

The ice bath feature - there’s a reason to be able to remotely start your cook.

1 Like

Ah, yes. My life would not be complete without that. Absolutely essential for happiness and fulfilment…

2 Likes