Anova won't connect to wi-fi!


I sent this inquiry to the support email address on 1/17/2023! No answer.

Admittedly, I have not used used my Anova in a while. This will be the second time and I’ve had it for a few years.

The unit is operating but it is not connecting to my wifi. My phone app sees it but when I try to make the final connection it spins and spins. I must have entered the network name and password 6 or 7 times. What am I doing wrong?

Thank you.
Carol Rhodes-Rice

I’ve just had the same problem.
You need to contact Anova support with your Anova serial number and the will fix you problem.

1 Like

Thank you! I did send an email to support but got nothing. So do they have a CS phone number?

Unplug and then re-plug in your Precision® Cooker WI-FI. Press and hold the WI-FI icon on the Precision® Cooker WI-FI until it beeps once (approximately 4 seconds) - this will clear any existing settings and will help connect you faster. The WI-FI restarting process can take upwards of one minute to complete.

Evidently the Anova app doesn’t play nice with some phones.

I have a OnePlus 10 Pro 5G phone running OxygenOS 12 (OnePlus’s version of Android 12). I followed directions very carefully to connect my APC to my wifi, but could not.

I also have a backup phone, a Motorola One Ace 5G. I fired it up and installed the Anova app on it. I then followed directions to connect the cooker and it connected immediately.

Once you get it connected, the Anova app will find it regardless of the phone it’s running on; i.e., my OnePlus phone accesses it with no problem, even given I used my Moto phone to connect it.

So, try another phone if you have one.

Never connects when you need it, waste of money

So, I am replying to my own post to update you on the steps I had to take to get my Anova to connect to the APP via wifi! I had to uninstall and reinstall the app, I had to shut off and restart my phone, I had to delete and clear the cache of the Anova app and force stop it before all of that. IT IS FRIGGIN RIDICULOUS!!! Nobody should have to jump through this many hoops just to get wifi to connect. The worst part? When I set up the timing of the sous vide, it didn’t count down the time!!! JUNK JUNK JUNK!

yous sous vide is fine, & works beautifully to cook food, read threads, use the scroll wheel, & forget the app for anything bar temp & time…

Anova don’t give a damn about the app, updates are few & far between, vent then forget the app, program by hand & set a timer on whatever you tend to use… easier than the frustration of crap pairing.

You know what’s funny is all that crap I went through a few days ago, I used my Anova again today and all the features worked. So maybe it was uninstalling and reinstalling the app? Even the timer works!

I hope it is genuine platform stability improvements over “got lucky” so many of us bought into the markered schtick of conncetivity that is likely the highest rated problem experienced by users for many many years now,with no proper resolution, …the completely 5h1t software is the biggest thing that puts people off when I explain the otherwise good results from owning a sous vide wand which has so many detractors (either the time it takes over standard cooking, or the “boil in the bag” pre-judging) …software is broken & left to rot by the developers, everyone here knows it & sadly accepts that trying to pair it by relying on broken software/ hardware to work just delays your cook process & frustrates but
years later the parent company havent learned 5h1t.

Guessing the original crowdfunders took the money from electrolux & ran!?

If it were not for being able to call up a timer via alexa / siri this product would likely be toast! …you even see the precocious kenji-alt “whoever” resorting to one in a serious eats video …because “broken, broken, broken”

Site software does not match the app (look at food guide temperatures, app only) which do not exist on the pc/ tablet accessed site recipes, so you still end up opening the app to verify temp & time to then program it in manually via the thankfully simple scroll wheel.

The anova team overstretched their ability to create a viable product that works compared to many internet & bluetooth otems around the home from the same era …& chose to ignore sorting it in favour of more bad design choices with the oven to continue their legacy of useful gadgety cr@p if we all learn to lower our expectations, …& considering our food cook standards & expectations are high enough to seek out & buy this kit the anova team do us an utter disservice.

Thank god the scroll wheel works!

nice box though eh!? :expressionless:

Same issue here, I managed to connect to WiFi when I used my Anova Pro with two Android devices (admitted this was a pain to get working). Anyhow, everything has been working fine, not used my Anova Pro for some time and tonight it can’t see the device. Followed all the stuff online uninstalling the APP and so on, I tried with a Samsung and an OPPO. The OPPO won’t play whatsoever and the Samsung gets to the enter my WIFI password and says connected only to go back to the APP and it can’t see the device???

I have heard they have a customer service phone number you can call but I don’t know what it is sorry.

  • Address

Anova Culinary, Inc.
667 Howard Street
San Francisco, CA 94105
P: 855.421.8282

  • Support

If you need help, please contact our support team at You can also find answers on our help desk and community site.

Our support team is available Monday – Friday from 9:00 am – 5:00 pm ET.

  • Returns

We offer a 100-day, no questions asked, money-back guarantee. Click here for the full return policy.

If you need to submit a return request, please contact use the return request form located here.

  • Mobile App Feedback

We love feedback. If you want to provide us with feedback about the mobile app, please visit our Feedback page.

I wouldn’t bother sending an email. I did that and never heard back from support.

Maybe phone, find out who needs a chewing out !?

What I received yesterday from email contact just the other day…

" Thanks for reaching out to Anova Culinary!

Your request (834133) has been received. Your ticket may take up to 72 hours to receive a response due to increased holiday volume. We thank you for your patience during this busy time!

In the meantime, you may find the answer to your question in our Help Center or by joining in on the conversations with the thousands of #anovafoodnerd members we have in our Community. 😊

For order status inquiries, please use our Order Look Up Tool.

For inventory status inquiries, please check our Inventory Status Page for the latest updates.

Happy holidays,
Team Anova
P: 855.421.8282


I need to correct myself, I heard back with that same confirmation email but then never heard a word more.

I have a OnePlus 10 Pro 5G phone running OxygenOS 12 (OnePlus’s version of Android 12). I followed directions very carefully to connect my APC to my wifi, but could


Yeah this is kind of crazy. I just bought an Anova pro, couldn’t connect it. I’m a pretty sophisticated user so already tried most troubleshooting steps by the time I reached out to support.

Went three rounds with support asking me to do advance networking configuration (which I had already done, but 99.9% of users wouldn’t know where to start with), with the rep just copy/pasting instructions for things I’d already make very clear I had already done. Then as a final volley sent me a list of over 30 different things to try configuring my router with that would have taken me all day to actually test, let alone left my network insecure and disrupted. I have to have a networking PhD now to connect a device? Can’t believe this is acceptable.

Wow, this can’t continue! How do we fight back?

You could open it up, the Mac address is on a sticker within the unit circuit board on the WI-FI module. which may make searching & hooking up a specific address faster, easier, & more reliable when required.

The majority of us have just given up on ever switching on & “voila” connectivity in a flash.