Flickering internal light on Precision Oven

My new Precision Oven internal light flickers while heating.

I have seen one other post with this same problem.

Do all ovens have this ‘feature’ or is is an fault/issue with a small number of ovens?

Thanks

1 Like

I’m having the same issue. My light is flickering for the heating element preperation. Not just during pre-heat, but the entire time.

Not sure if +1 with this problem is good or bad!

Once my oven reaches temperature the flickering is intermittent - pretty sure it is tied directly to the periods when the element turns on/off just to maintain the temperature. When I open the door the light is steady.

I contacted Anova support and will post any reply here…

I’m seeing the exact same issue with my oven. I’ve tried the oven on a few different 20A circuits. If the heating element is on, the light flickers.

Same here re different 20A circuit. Tried the same thing without any improvement.

Add me to the list of people with the same issue.

Same issue :slight_smile:

Same

I posted same in my hour 1 update thread. I have not yet found a way to disable to light using the app etc. Fairly certain this is a hardware problem since the light is incandescent and line level. The power for the light is impaired by the rush of power needed for the heat cycling most likely.

I hope they have software control of the light and we can at least toggle it off with a firmware update. Otherwise, I may have to remove the bulb. I find it annoying, but the home operations manager says it needs to stop. This strobe is totally ruining our time lapse video of bread rising.

Latest from Anova support:


The light flickering can happen when the Oven is used on a 10A circuit or an outlet that has too many things on it.

Something that might help is connecting your Oven to a mobile device and checking for an update. The most recent update helps reduce the flickering a bit.


I have tried two 20A circuits (no other load) and my oven is on firmware Rev 1.0.1 reporting as up to date…

Have suggested support review this thread to see other people with the same issue.

Yea, I’ve moved it to a 20A breaker that isn’t gfci or afci with only the oven on the circuit. I’m on 1.0.1. Still flickers.

I completely sympathize if you are taking photos/videos. But just looking at the oven while cooking something, it’s a little annoying, not a deal breaker IMO.

If you aren’t epileptic, perhaps.

I have this issue too. I also cannot update the oven, it seems to fail at 45% every time

1 Like

Just arrived today and started the break in process…Same flickering. Rev 1.0.1 - super annoying - makes my eyes twitch. Why even leave the light on continuously during cooking anyway? Please fix this Anova (checks return policy)!

I have the same issue. Also on a 20A circuit with nothing else on it.

Same here, can’t update to 1.0.1, keeps on resetting halfway through the update!

Out of curiosity, have you power cycled the oven between attempts to update?

1 Like

Yes and unfortunately it didn’t help

I connected an very old belkin router and upgrade worked!

1 Like