Anova One resets while cooking, support is unresponsive

I purchased an Anova One in late April 2014. I’ve used it regularly since then, probably once a week if not more.

The last two times I tried to use it, the unit would shut off and restart after a few seconds or minutes. I was able to continue cooking by pressing the “Start” button after each reset.

I contacted Anova support on November 6, and didn’t get a response until today. The support person (Jona De Guzman) closed my ticket without offering any assistance. The entirety of her message was “Sorry for the delays in getting back to you. May I please ask if this is still an issue.”

I’ve tried calling, only to be sent to voicemail.

Has anyone had success dealing with support? So far they have been unreachable and the responses have been unhelpful.

@bhigh, we’re sorry to hear you’ve been having issues with your Anova One. If this issue is still persisting, we’d like to get this taken care of. If you can confirm that you’re still having a problem the power we’ll want to get the faulty unit back and swap out with one that is working correctly.

Thank you

I have the same problems - both with the unit, and with the service. I received my Anova One on November 6, and tried cooking with it. It reset repeatedly over the course of 3 hours. My expectation would have been a single phone call, followed by a return authorization and quick exchange. 9 days after my first contact, I was told that the repairs team will be contacting me “within 48 hours”. (time’s up) I would like an exchange, and if offered anything less, will just send it back to Amazon.

I give up. Mine is going back to Amazon, and I canceled my Precision Cooker order. This is not the kind of customer service I expected. I’m disappointed because I’m probably going to settle for an immersion circulator that doesn’t review as well, but at least maybe they’ll respond to their customers. I was hoping for a different outcome.

im having that issue too and have been trying to figure out if its the machine or me not knowing what im doing

I’ve just started having this issue myself purchased the unit in may and it now keeps resetting every couple of minutes…

@jordan_poudrier‌ Please submit a return request here: https://anovaculinary.com/pages/returns/

I had the same issue when I got mine (in March 2014). I was given a shipping label to return the unit, but their support personal claimed they were not able to reproduce the problem in their lab and said they would be returning the (defective) unit to me.

Luckily I had taken a video of the unit resetting multiple times during a short cook. After I showed them the video they quickly offered to exchange the unit for a new one.

I agree with the other posters though, taking the defective unit back and shipping me a new one should have been their first and only action.

It was definitely the machine though. The replacement unit I got has been working like a charm, and I’ve not had any problems with it.

I got my new Precision cooker a couple of days ago and tonight used it for the first time. After less than 2 hours @130 F my unit starting doing the same thing. It was re-booting itself. There were no high temp warnings, etc. Water level fine, etc. It was working fine until it wasn’t. It continued to re-boot itself around 10 seconds after I would press the start button. Finally, after I left it alone for a few minutes I hit start again and so far it has stayed on for about 15 minutes… hope it stays on until my food is done!

I have opened a support ticket and will post the results here.

Anova support responded within a few hours. This was on a Sunday! That’s above and beyond expectations. They gave me the link for Returns and I’ve submitted the request.

Thanks @vette67‌ ! We have your return info and will process asap ! thank you again.