How to change the fuse?

After 4 uses, my Precision Cooker stopped heating. Circulating, yes. Heating, no. Over the past 10 days, I’ve been communicating with the support staff who yesterday asked if I had tried to replace the fuse. Today they told me where to find the fuse, in the “hidden drawer” directly below the plug but gave no additional instructions about the fuses. I read in another thread that there should be 2 fuses in that tray, the replacement and the original fuse. My drawer has only one fuse in it. Does anyone know where this replacement fuse needs to go? I’ve looked online for drawings or instructions to show how to change the fuse to no avail. Any help would be appreciated. Super frustrated with the situation.

Hi @Rhonda, thanks for your message. Below is an image of where the spare fuse may be found:

[missing image removed]

The area marked #4 should contain the fuse. If not, please let me know as we may need to send you a new unit.

I started heating the water tonight to cook and after a minute or so the unit went dead, I don’t have the unit shown in your picture. What do I need to do to fix it or replace it? Please make this easy! I have enjoyed my Precision until tonight’s disappointment!

Hi @Dan13 - I left a reply for you in the other thread but if you didnt see it - head to this link here: http://anovaculinary.com/pages/returns/ and fill out the info, then mention youre looking for an exchange :slight_smile:


The team will take care of you!

Hey @Bill -thanks for the replie! I was able to make an exchange and love using my Anova!

I had this problem, with “replacement” being the only solution offered by Anova ($200 for out of warranty). I had a time of it, finding the fuse “drawer,” and the drawing makes it a little odd. #3 and #4 are actually in the same, black receptacle.

There’s a black 120V AC electrical connection which accepts the female end of the main power cord. It has 3 male prongs, and looks like a standard socket you’d see at the back of a computer.

If you look Very Closely at that receptacle, you’ll see the outline of the fuse “drawer.” It’s located at the #4 position in the drawing, but it’s actually a part of the AC receptacle. Then; if you look just inside the recessed area of the receptacle, where the three male prongs stick out, you’ll see a small indentation just on top of this drawer. That’s where you can fit a small screwdriver blade or butter knife blade and gently push outwards. That will easily pop out the little drawer.

In the fuse drawer, you’ll see the main, working fuse held in two clips. Next to it, you’ll see another fuse (the spare) with no contact clips. It’s just sitting there, easy to take out and use to replace the one in the clips.
-----------------
The fuse is a 20x5 (20mm by 5mm) Fast-Acting 10A (ten amp), 120V (one-hundred twenty volt) fuse. I had to do a lot of research, then have a professional electrician examine the blown fuse under a high-power magnifying glass. Despite Anova telling people it’s a 15A fuse, it’s not! It’s 10 Amps.
----------------
They can be purchased in many places, and I happen to have an electronics parts store in town. The store sells things like cables for TVs, DVRs, and so forth. It’s like a Radio Shack used to be. If you have a place like this, you can typically get a 5-pack of the fuses for around $3.50 USD. If not, you can find them online at all sorts of electronics parts suppliers.

I’ve used my circulator often for over 3 years. The fuse blew, and left a very clean break. The guy I spoke with explained that over time, sending constant electricity through the fuse will degrade the metal. It gets a little old, and wears out. The metal of the fuse just breaks. It’s a clean break, with no discoloration. Like mine did. The unit ran for about 5 minutes, then simply stopped.

On the other hand, a short circuit in the system likely will cause the fuse to blow and leave  blackened area inside the glass. People have spoken of a blackened area in the clamp area where the AC power cord connects. That’s likely due to a 15A fuse being in there, failing to prevent a spike or other problem and burning the equipment. It might explain why power cords are melting in some postings.

Replacing this fuse is so easy, it’s clearly designed as a user-replaceable item. There are no instructions with the circulator on the Flash drive or reference PDF file, and I’ve found no information online. One community member helped a lot!..by mentioning in the FAQ, in passing, the extra fuse. I didn’t even know there is a “Community!” This post is to validate that information and provide folks with the specific fuse for this unit. Hope it helps. Remember, you do NOT have to unscrew anything in the clamp, or even use a screwdriver or other tool at all. You only need a way to open the little drawer, and you could probably do that with a fingernail.

1 Like

Is this actually the right fuse??? Can somebody from ANOVA reply since your website doesn’t actually point this out at any place I’ve found searching and I’ve spent hours now looking online and on the anova page any there are many different ideas circulating?

Hi Shea,

I see you have posted on both topics. The answer is it depends on which unit you have. If you have the Anova One, the fuse is replaceable and is a general fuse, 5 mm (diameter) X 20 mm (length) size. PN: T15AL250VP. But if you have a newer unit, it unfortunately is not replaceable.

I hope that helps and let me know if you have any more questions!

I have the Anova One, I think…one of the original ones from back around 2013. It blew the fuse, and I bought the above fuses and replaced the one that blew. Worked exactly the same as the original, looks exactly the same. No, I didn’t see anything from Anova, but it looks as though the below response is from them. Bottom line: It works fine, looks the same, and the electronics guy at the supply store said it was the same.

1 Like

Thank you so much for this. With your help I was able to get my old machine humming once again.

1 Like

I have a very similar issue with my Anova Precision Cooker Nano (just circulating water but no heating), but can’t find instructions regarding how to find the fuse or how to disassemble the device.

Does anyone know how to do this?

Thanks

I don’t know if it is possible. Best bet is to talk to support. Email support@anovaculinary.com or use the phone number listed on the website.

I have Anova Precision Cooker used it only once , circulating yes but temp not rising even by trying manually or through the app
Do you think the issue could be of the fuse ?
Would it help to change the fuse .
What else could he the problem it doesn’t rise beyond 93 F. Thanks for any advise