Timer display in APP ?

I did find this question posted here on your forum https://community.anovaculinary.com/t/app-remaining-time-timer-bug-report/7733

Well, me too. Same. What gives ?

Zqushair didn’t get an answer so I’m asking here also. How come the timer display in the app isn’t showing the time on the unit ? I set the timer in the app to begin with (not manually on the unit). The unit is displaying the correct timer info but nada in the app when I check it.

This can not possibly be by design !

I am Wifi connected (after a frustrating and annoying battle). The app now seems to reliably and stably see the unit and based on it reporting the correct temperature there must be communication. So why am I not seeing my timer ?

Replying to myself (for the benefit of others who might find themselves in a similar predicament), I have discovered that if I go through a few clicks in the app as if I were trying to SET TIMER/TEMPERATURE/COOK (but in actuality just checking it and making NO changes), I can see the current status of my cook - both time remaining and current temperature. Tada !

You may call this “fixed” or “solved” or “of course, this is how it’s suppose to be”. But I will say it’s counter-intuitive and kinda stupid. But hey, it’s usable, so there’s that :slight_smile:

Hmm, I can see how that particular feature can be improved in the app. I will bring on that feedback to the rest of the team! If I have more information on this, I’ll also report back here. Thanks for bringing that up! :slight_smile:

It’s just bad coding if you ask me. The app must display the current temp, set temp, time gone and time remaining. That can’t be too difficult… The whole point of having the app is lost due to the lack of those most basic things.

@Gee we are aware of this issue and I’m checking on its status with developers. Thank you for reporting it.

1 Like

I am still having the same issue, screenshot attached - timer is blank when cooking from a recipe, happens with all recipes.

1 Like

Ever since the last update im having the same issue, also if my wifi isnt connected it wont work on bluetooth?


Same thing here. Once you have lost a connection and reconnect the temrerature is displayed fine but the timer shows nothing in the app. On the device it is still running fine.

Seems to be fixed now, I haven’t had this problem in about 4 months. Thanks Anova

I have same issue. Time not accurately display on apps

2+ years and still not fixed. Anova staff, please don’t respond until you’ve fixed the problem rather than giving your cute responses that you’ll have the “team” look into it. Shittiest customer service ever.

I feel your pain. I started the topic and I gave up along time ago.

BTW, I had an earlier post in this topic and I use a much more innocent “S”-word and they took my post down. I used the word “STUPID”. I don’t think your post will last very long on here, but too late, already saw it ! :smile: