UK Version - Temperature Stability Issue

Hey guys,

Well today’s the day I’ve finally received my APO! I remember when it was first announced over 4 years ago and back then I was super super excited and from that point I used to check for updates on the oven almost every month, until finally on the 12th of April 2021, it had arrived at my doorstep.

I first tried a normal cook at 200c and I was surprised how stable the temperature was in the normal temp mode. But unfortunately I’m getting issues with sous vide mode, which is the feature I’m mostly interested in.

I tried to do a few little tests to see if everything’s working, and I tried a test at 63c in sous vide mode. When it pre-heated it over-shot the set temp by a few degrees, and slowly started to creep down. It went to 62.5c, before very quickly heating up until it reached 65c. It then slowly crept down in temp until 62.5c, before again quickly over-shooting to 65c. It kept repeating this same action over and over.

I was just wondering if anyone else in the UK has experienced this problem? Or if just an issue with my specific oven. I’ve ran through all the ‘burning in’ tests and did one cook with it so it should be sufficiently burned in. I’ve also contacted Anova directly to flag this up with them in case it’s an issue with more than one device.