Video: Setting the Timer / Temperature

Here is a quick video to reference if you have run into issues setting the timer and keeping the temperature set in F. Setting the timer/temp

The video with no sound is not very helpful. I can get to the settings, but the steps are unclear. Is there a written explanation you can send? Also, is it possible to see what the timer has remaining after it is set?
I understand there are pdf instructions but I cant find them on the site.

Hold “Play” for 8 seconds… this will flip to the temperature readout to C or F, depending on what it was before and then once 8s has passed your timer icon should appear.

Hold timer icon for 3s and then use wheel to set time. Press timer icon to start timer (no need to hold). Hold the play button again for 3s to flip back to your preferred temperature readout.

The time of the timer will show in the ‘set’ field (bottom numbers) and alternate between set temperature and time remaining on timer.

1 Like

Ok that worked. The manual is really not right, you should revise it

somthe problem is not solved. When i get the timer set it is in farehheit, and then the display toggles between temp and time. When I put it back to celsius (which is what I want), then it no longer toggles between the timer and the temp
So can you please address this problem

somthe problem is not solved. When i get the timer set it is in farehheit, and then the display toggles between temp and time. When I put it back to celsius (which is what I want), then it no longer toggles between the timer and the temp So can you please address this problem

I’m just a user, not anyone at Anova. It sounds like you didn’t set the timer before swapping back to your preferred temperature readout? I’ve not experienced what you are talking about.

1 Like

@shelmica Once you’ve set your timer and switched the temp back to Celsius, you’ll still be able to view the timer countdown. Your Precision Cooker will toggle back and forth between the temp display and the timer countdown.

Also, the video does have sound it just may need to be played with the speakers at a higher volume due to the recording quality :slight_smile:

I was wondering why the timer icon is not just automatically displayed like the bluetooth icon instead of having to go through the temperature change etc.

Not like anything else is displayed there.

I know the timer is not very functional, but I like to use it as a reference for how long something has been cooking so I mostly just leave the unit plugged in to avoid having to go through the steps. Not that hard to do I know, but irritating all the same.

@Helen The interface was designed to focus more on the temperature and less on the time and we've gotten a lot of feedback about the usability of the feature. We've heard the frustration it's caused and will definitely note it for the future, the app should also help take some of the trouble out of using the timer.

Here’s one way of using the timer with Celsius temperature:

  1. Bring it to the temperature you want.
  2. Press and hold the start button until you see “F” for Fahrenheit.
  3. Turn the machine off. It will remember the “F”.
  4. Turn it back on. Ignore the temperature numbers - they’re in Fahrenheit.
  5. Press and hold the start button. Smile as it changes back to “C” and your temperature numbers come back, but don’t let go until you see the clock image appear. That’s your timer button.
  6. Press and hold the timer button until it responds - about three seconds.
  7. Set the time you want with the winder.
  8. Press the timer button again to say you really mean it.
  9. Press the start button. When the timer is finished it will keep going bip-bip-bip until you attend to it.
1 Like

Just a quick update: We are working on making some more videos that include written instructions to make the process easier!

1 Like

So is there a way to set the timer from the app? It doesn’t sound like it. I feel like this is something that could easily be added to an app update. Jordan, anything to say about this.

1 Like

Hi @bennybigballs, there actually two ways to set the timer from the app:

  1. If you start the cook from a recipe, the timer will automatically set to what the time if for that recipe.
  2. You can manually set if from the app to this you need to:
    a. Click start cook (at the bottom of the image in green)

b. Click “set timer” right under “set temperature”

c. Then this screen will pop up and you can set your desired temp!

The images will vary a little bit depending on what app you have. For example, andriod will be a little different from IOS (what I showed here)

I hope that helps!

Hi there,

Regarding your comment about the timer feature on the app, I have to say I find this doesn’t work very well from my limited experience. Both times I have tried to manually set it from the app, using the exact method (method 2) that you have suggested here. The only reason I have in fact found this forum however is because I have been googling ‘anova problem with timer’ to see if anyone else has had the same problems as me. Specifically, my issues when doing what you recommend were as follows:

1 - The first time that I did this I thought I had set my poached eggs to boil for 45 minutes using the method you described, I then walked off to another room and hung out for a while, distracted with other things in life but assuming I was going to get some kind of beep from my phone or the sous vide machine when it was all ready and done. Eventually, feeling sure that we must be close to the end time, I looked at my phone to discover that the bluetooth connection (I do not own the WiFi version) didn’t seem to travel as far as the other room, which was in itself a surprise given I use bluetooth with my music speaker at home all the time and the connection goes twice as far. I figured however that maybe the timing had messed up as a result of this connection issue - you live and learn and I had to give the benefit of the doubt that the bluetooth connection was the key problem, even though I hadn’t strayed that far from the kitchen area. Hence I tried again.

2 - The second time I did the same as before but this time after I set the timer I waited and watched it closely to make sure that it started to count down after I had set my app. The timer didn’t move however and just stayed at 45 until, eventually, the numbers disappeared completely from the display as if I had never set a time at all in the first place. I found this really bizarre because I was so deliberate about doing it. I had to try for a second and third time before the timer finally set.

And on that point of checking to see if the timer had in fact set, correct me if I am wrong but in that first minute after you think you have set the timer there appears to be no way to know for sure whether the timer has really set and is counting down or not because no seconds are displayed on the device, only minutes and hours. So, if this is a problem then the only way a user can be sure his item is working properly is by waiting a whole minute for the number to start counting down.

I’m now paranoid that if I ever cook something with this item then I am going to have to be chained to the kitchen because the wifi might cut out. I also need to constantly check my app to be sure that the timer has set and doesn’t unset itself. Suffice to say that this isn’t the relaxing experience overall that I would have expected. Am I missing something? Please can you advise me whether there are any basic things that I can do which will stop the above from being issues the next time I use this device (I don’t want to have to wait for the next software update before I can use this in confidence again).

Thanks

I too have found this thread due to finding setting the timer not simple to do. Here’s what I find frustrating, that no one else appears to have addressed. I set the cook temp and time using a guide for reference. However after setting it, I want to CHANGE the time via the app, for whatever reason (today my reason is that I want to add 30 min to the time to account for frozen meat). Once set via the guide, however, I do not appear to be able to change it, no matter what I try. So I find myself setting a manual timer on my phone and I will simply ignore the timer on the Anova app when it goes off. I would like to recommend this change to the app…

You guys really need to add how to set the timer to the manual that comes with the unit. People shouldn’t have to search the internet for instructions.

I wonder of anyone has solved this. I just bought by Anova (replacing a first generation Sansaire that was literally falling apart) and found the same thing with the timer. Set 20:00 for salmon and the timer did not move. Manually turned it off after twenty minutes. I’d love a solution.

Don’t use the Anova timer and set an alarm clock instead. Works every time and doesn’t require a network.

2 Likes

I must say that the timer is still very buggy, even with the wifi version. It is also extremely disappointing that the timer cannot shut off the Anova. I understand the principle that “time isn’t very important” but then I would ask to be presented with the simple option of turning off the anova when the timer is done. I would not be setting a timer if I did not expect to shut it off at the completion of that timer. If I am unsatisfied with the cooking level, I can always start it again.

Please please add this feature, it would make the use of this device much easier for me and many other people, especially as the timer itself often stops working and I have to keep checking it and use some other timer, like okay google.

1 Like

It seems best not to use the timer at all. It does not add anything useful. The timer does not turn off the Anova. And it does not turn off the beeps. Even if I stop the Anova from the app once the timer expires, set a new timer, and restart the Anova, the Anova continues beeping forever until I finally walk over there to stop it beeping by pressing the start/stop button.

So, what’s the point of the timer? It doesn’t turn the unit off, and it doesn’t stop the beeps. As far as I can see, it does nothing useful other than to say “timer expired” and sending the Anova into an annoying never-ending sequence of beeps.

It really makes more sense to just set an egg timer or alarm on your phone, and walk over to the Anova to turn it off once the alarm goes off. You have to do all these things anyway, whether you use the Anova timer or some other alarm.

If you really don’t want to get out of your seat, still use an alarm on the phone and, if you want the Anova to turn off without having to do it at the unit, use the app to turn it off. At least that avoids the endless beeping.

1 Like