Anova Precision Cooker died after first use


My name is Ian. I live in Brazil. Recently I travelled to NY and, having heard so many good things about the Anova Precision Cooker, I bought one for myself. (I bought the Anova Culinary A2.2-120V-US Sous Vide Precision Cooker Bluetooth, Immersion Circulator, 800 Watts)

When I arrived home, I tested it out with a ribeye steak. It cooked for 1h and it worked perfectly. After use, I plugged it out, cleaned the Precision Cooker, let it dry and then I stored back in its box.

The next day, I decided to use it again, but alas, it does not turn on AT ALL. I tried several power outlets. All of the outlets are working fine but my Anova Precision Cooker just doesn’t turn on.

Please, what should I do?

Contact Anova Support.

1 Like

Hey there. Please note @Ember’s advice.

I wonder if it might be because you got water in the head unit while cleaning it. Hope the support team can help you out!

I had the same issue (although in United States rather than Brazil.) I e-mailed support on September 8, and I’ll let you know if they are able to resolve it!

1 Like