Re-set anova pro

Does anyone know how to re-set the Anova pro? Was advised to do this by Anova support when my new pro stopped heating the water but can’t find any information or instruction as to how to do this?

Surprised Support didn’t say how to do it when they told you to reset it.

Might be something in the Support section for the unit here.

found this: reset by unplugging it and replugging it back in.


“How do you reset an Anova?
Unplug and then re-plug in your Precision® Cooker WI-FI. Press and hold the WI-FI icon on the Precision® Cooker WI-FI until it beeps once (approximately 4 seconds) - this will clear any existing settings and will help connect you faster. The WI-FI restarting process can take upwards of one minute to complete.”

I will add that if the Anova will not pair on Wifi (or BT?) then redownload the app and try again.

Thank you, but as far as I’m aware and have been advised, the Anova Precision Cooker Pro does not yet have an a WI-FI app. When my Pro stopped heating the water (midway during an event I was catering), I was advised by support.anovaculinery.com to reset it. Other than unplugging and replugging, resting and drying (both unsuccessful) I would like to know how to reset the Pro as advised ?

Thank you, but tried this straight away, and was unsuccessful. This is an Anova Pro which does not have connectivity so was wondering how to reset it to restore water heating (which suddenly failed mid cook), as instructed by Support.

First. Sorry if I upset you in what I know is a distressing situation. And I really sympathise with the “dead mid cook” bit. Been there done that. Can cost you not just your honour but a lot of food if not compensated for.

OK. I am a little puzzled.

Did you try the full procedure described as I posted it (not just unplugging and replugging)? Did you do the hold down the Wifi button bit? I assume it has a WiFi button. From what I read, they intend to introduce and app? I am not up with the latest and all their namings are too similar and interwoven to sort out easily (almost I may say…weasely :slight_smile: )

Sorry. I did not know it had no app. That was just a suggestion. I have an Anova that does have an app, but it was so awful that having to reload it all the time meant that I (and many others) resorted to just turning it on, setting the temp, and using or own timers.

However, regarding drying: I have had a couple of ailed heatings during a cook. What caused mine was steam getting through the ventilation grate at the back of the machine (which I reckon should be further up the body) and gets the gizzards wet. To really dry it, you need to actually pull the body apart (there goes the warranty) and leave it in the sun; that has worked for me both times… But you could try careful application of a hair dryer into that same vent, making sure you are blowing plenty of air and not too much temperature: keep the dryer away from the vent by a few inches. Let it run for some time (5-10 mins while monitoring) and have another go.

OR, you could assume it is faulty and ask for exchange or refund. Tell them you have tried the methods they suggest and it has not worked. I have found them to be extremely generous about warranty replacements.

The device in question is the new Anova PRO, not the regular Anova.

https://images-na.ssl-images-amazon.com/images/I/71gc0WJ77wL.SX425.jpg

Oh well, I tried. I can’t help.

Hi Carol. Did you find out how to reset your pro?
I have the same issue and wondering how to make it work again

Hi Michael, was told to reset by turning off then on, but the pro never came back to life despite resting and drying for months.

I hope you contacted Anova support about the warranty.

Yes, Anova support was great and the unit was replaced. However the new pro developed a loud rattle - wondering if this model was worth the considerable extra cost. The new Precision model we own seems a better bet.