Anova Wifi unboxing


I received the Wifi  preorder from Sept 11 on Oct 31. Shipped on Oct 27. 
It came in a rectangular box, 8x6x16 inches per Fedex. The shipping box was pretty much the same size as the box inside. No tube, a heavy duty rectangular cardboard box with a light duty plastic insert to protect the contents. No manuals in the box. I downloaded the quick start and regular manuals from the website.They need to add info about assembly and disassembly from the bluetooth version to the Wifi version.

I ran a basic test with settings at 130 F and 135 F. Worked fine with temps verified with a Thermoworks Chefalarm.
I ran a second test at 165 F and the temp reading began fluctuating after 30 minutes and the water temp was at 180+.
So I guess I have a defective unit. Now what?  I can request a refund, or wait for the support line to reopen to find other options. Is there a replacement request option? I suspect my best choice is to ask for a refund and order the regular model since I don’t expect to use either the Wifi or bluetooth option. I opted for the Wifi because of the discount.

Best to just get  a replacement I think? Probably faster than a new order. And cheaper too.

They should ship your replacement as soon as you give them a tracking number. They pay the cost of shipping but you need a RMA which they will email to you.

I think they might be having quality control issues and am sorry to see this on the new model.

I have been thinking to get one but am but am put off by the fact that there isn't a true (multiplatform) WiFi app, not that I need it, but why else would I get the new model.

Also two weeks after the initial shipping yours is the first review/comment I can find anywhere. How weird is that?  

Better not to ship than to ship another almost working model with quality control issues.

@Helen said:
Also two weeks after the initial shipping yours is the first review/comment I can find anywhere. How weird is that?  

They’re popping up on reddit (/r/sousvide) here and there.

I left it unplugged overnight still in the water bath. I plugged it in this morning and the temperature reading seemed relatively stable (± 0.1F) when it had been bouncing 2-5F when it went nuts last night. I pressed start and it seemed to behave, so I did some 65C 45 minute eggs. My independent thermometer verified the temperature.

Apparently it is either intermittent or some transient problem. It had only been out of the box a few hours when it started acting up.

I cranked it up to 95C to see if higher temperatures were a problem, It seems to be stable for now but my confidence is not high.

Hopefully will be fine. If not they will replace it very quickly I am sure. Have fun cooking:)

Just an update. I have run several tests and a few inexpensive recipes without having any further temperature problems. I don’t know what happened the first day, but I haven’t been able to recreate it.