Brand new Precision Oven WiFi and app not connecting

Just received my Precision Oven today. So excited but then… Tried connecting the app with it.

  1. Pressed WiFi icon 6 seconds. 4 digit code showed up
  2. Clicked “Connect Oven” in app. Entered the 4 digit code
  3. App showed “Connect to device dialog”. I selected “Connect”
  4. App flashed “connecting to device…”
  5. App flashed “connection successful”
  6. App waited for like 30 seconds and then back to that “enter code” screen with a “retry” button!

I have tried this like 10 times and it’s the same. Even did a WiFi+Power button 8 second hack from some of these posts. Oven screen did go into all-segment-on and then back to normal, so I suppose it had reset itself.

What can be the cause of all these?

Thanks an advance in helping out! So looking forward to start using it this weekend…


Do yo have another phone. Try another phone. I received my oven yesterday and I could connect without any trouble.

However my oven is apparently defective in another way in that the door doesn’t close all the way on one side… good idea to make sure your door closes completely on both sides… I can’t even force mine closed.

@Franknozly Just tried with another Samsung Galaxy Note10 running Android 10 and results is the same…

Anova is quick to respond making some suggestions (no power strip etc.) but results remain the same. Let’s see how this case can be solved…

Finally solved with an older phone, Galaxy S9+ with Android 10. No problem with the procedure at all. So I guess it’s an app compatibility problem. Hope Anova can solve it for future users.

I was able to connect my Precision Oven to WiFi, but it disconnects during use. Any suggestions?

just another datapoint. I’m using oneplus 7t pro and it’s on Android 10. Works fine for me.