Wi-Fi Setup

Hi all!

I have been trying to connect my Anova Precision Oven and it always stop at the last step, can’t seem possibile to find a solution and it is frustrating.

I press the Wi-Fi button, the phone with the APP connects to it (through the 4 digits code) and everything seems to go fine until it asks to choose the network and then “Connecting” seems to take too long before resulting into a message of error.

I have tried with different networks and nothing changes. I have also tried all the procedures suggested (unplug the oven, uninstall the app, etc…) but - again! - no success.

The support suggested to reset the oven by bypressing and holding the Start and WiFi buttons until the entire display lights up but the only result was that I have probably downgraded the firmware and now the first connection (with the 4 digits) works maybe once every three times, so even more frustrating.

The APP is installed on an iPhone 11 Pro.

Anyone experienced anything similar? Any suggestion?

Have a nice Sunday!

Hi ya @eb1981mi Emanuele

Based ONLY on my experience, not logic; make the initial connection with the APO and iPhone as physically close as practicable to the modem router. Once I did that the connection has been reliable.

iPhone 11 is a bit long in the tooth. Have you updated the software regularly, is it even still supported? Make sure that your Bluetooth is upto date.

Best wishes.

1 Like

Hey Douglas! Thank you very much for your help and the suggestion… I will give it a try and see if it works then.

Temporarily turn off 5GHz on your WiFi and then try to connect it for the first time. Sometimes these smart appliances have trouble if there’s a 2.4 and 5Ghz WiFi signal on the same SSID, as the router will try to force it to the 5G side.


1 Like

Thank you Timothy! I have tried that before and it is not working unfortunately. :frowning:

How about your encryption selection? Are you currently deploying WPA2/3? Try with just WPA2.