Does anyone have a fix for WiFi connection issues?

My WiFi unit will not connect to my network. Bluetooth pairs and the WiFi network name appears, but the app gives me an
'Whoops" message repeatedly. Tried resetting the cooker, app, phone, router and reinstall in the app. The cooker function over Bluetooth with the non-WiFi app. Anyone have ideas?

What frequency is your WiFi using? I could not get it to connect to my 5Ghz network. That same router also has a 2.4Ghz network and that one works without issue.

@cschaaf said:
What frequency is your WiFi using? I could not get it to connect to my 5Ghz network. That same router also has a 2.4Ghz network and that one works without issue.

This makes sense. For this model they skimped on the heating spec (800 watt) and they probably also skimped on using a dual band wi-fi reciever. None of their specifications mention ether dual band or 5GHz.

Thanks for the ideas. I’m pretty sure the router is 2.4hz since its older. I purchased the PC at an Apple Store. I explained my issue and they were kind enough to replace the unit. I’ll report if this fixes the problem when I get a chance to set it up.

Okay. I find this interesting. My router is a Motorola NVG510 from AT&T. It runs on a DSL line. Speeds are usually around 12-15 MBs. The date code is 6/29/2012. The replacement unit still won’t connect to this router. The app has been re-installed before I plugged the new PC into power. But the app is now different. It shows my WiFi password rather than “***” as before. The on-screen prompts are “in-app”. They display within the app vs. notification overlays. And once I get the “Whoops…” message there is a new link to a support (Google) doc that has me fill in fields to describe my situation. It’s still not working, but it seems like progress. I’m wondering if this would have happened with the old unit.? 

The app was recently updated to show the WiFi password rather than to * it out. The changes you are seeing have nothing to do with the PC, it’s all changes that were made to the app.

I tried searching for your router, but I can’t find any specs that show if it can operate in 2.4Ghz. Can you get into the router settings and peek around?

After doing a cursory google search, the first hit was this guy:  Not a great review, but he does give a link to the manual for your modem / WAP combo:

Get into the configuration of your WAP and make sure that it’s in B+G+N mode - if it’s only supporting one flavour of 802.11, that could be your problem.

And, yes, I suspect there was nothing wrong with your first PC.  As you’re having the same problems with this unit, you need to figure out what’s happening with your WAP that is making connecting to it so difficult.

Thanks everyone for the input. I also thing the first PC was fine and that the problem is my network. Actually I went back to the store to see if I could buy the first PC again, but they said is was gone already. Makes me feel really wasteful and lazy. “Not very good” is all I read about the NVG510. Still can’t figure out if this runs 2.4GHz or 5GHz. I guess 2.4GHz because of the age. The router is running B+G+N and I’ve tried different security/no security. Same issue. What are your thoughts on adding an Airport Express to the network? 

You definitely can add another wireless router behind your AT&T one.  Before you do though, did you purchase this from AT&T or is it a rental?  (if it’s a rental, I’d be returning it and asking for a different model).

If you purchased it, you can add another wireless router behind it and the Apple ones are pretty robust.  Here someone’s already posted instructions on how to do it:

It works!  Again, thanks to everyone for input. I had to turn “Off” “Hide SSID”. I was set to go buy a router, but first thought I’d look through my NVG510 settings again. Even though my network name showed up in the app the PC must not have been able to find it with a hidden SSID. I’m guessing the app pulls the network name from my phone not from the network itself. I’m feeling pretty dumb, but I’m glad it’s working. Also I’m able to turn “On” “Hide SSID” once the PC has connected and the app still works. I’ve tested it over LTE also.

Nice work, tthomashardie. Glad you got that solved. 

This will surely help some other folks, too.

> I just received this tonight and was just about to return this to Amazon the very next day.  What’s the point of buying an expensive wireless network device (regardless of what it is) if the wireless network feature doesn’t work?  

Just to preface my tech knowledge I am a network engineer, 19 years in.  My assessment of this device?  Spotty, extremely and very very spotty.  It is hit or miss to get it connected to your network.

It took me an hour to get this device to connect but I finally did.  Tested through Android LTE connection with no BT or Wireless connection.  Yes, there are some basic steps to make sure you have the settings correct on your phone\pc\laptop\tablet but it shouldn’t be this hard to get it to connect.  Once you DO have it connected it is on the network for good unless the environment changes.  

I will cut the rest of this story short.  I have tested and modified numerous settings in my 2.4ghz router to get this to work and ultimately my assessment is such:

You will have to constantly attempt to change any variable within all 3 devices to get it to sync with each other.  My three are as follows:  1. My router 2. My Galaxy Note 4 and 3. The Anova itself.  

What this means is keep resetting the Anova as per Anovas instructions to reset the device AND\OR keep killing the Anova App on your smartphone, clearing cache, and data, and force stop AND\OR keep changing any variable on your router settings thru admin.  You have to constantly cycle between these three to get the app to finally sync (or Catch) all three devices.  It is actually quite sad.  

The last thing I did was force two password changes on my router after cycling between all three devices and that is when it connected after the router saved the final change.  So, a setting change in the router (refreshed) and I was connected.  

Maybe just buy the Anova bluetooth version.  It is on sale right now on Amazon for $139.00 ends in a few hours.  Good luck.

@Skunkpu Sorry, but your experiences aren’t necessarily the norm.   Now, I’m using the iOS app (and I’m on the beta), but it’s been pretty easy to get these connected provided:

- you’re not doing mac filtering on your network
- you’re using 2.4GHz (you can have a 5GHz network, but your phone needs to be connected to the 2.4GHz network for setup)
- you’re not hiding your SSID (at least initially)
- you’re supporting 802.11 B/G/N (the PC doesn’t support AC)

Once the PC has the network info, it connects via your network to Anova’s cloud.  Then your mobile device can use any data connection to get to Anova’s cloud and tunnel the connection back to the PC.

Any shortcomings I’ve encountered are with the app…and it’ll get better with more development.  

I never eluded to my experience as being the norm.  Just providing a scenario with my tailored equipment and what worked for me.  Simple as that.  What point am I trying to make re:my op?  

It is that successful WIFI connectivity had nothing to do with my current network or my android device.  I don’t want to say it was random.  I will say that making multiple password changes on my network security, reconnecting WIFI thru my android device with the new password, and then using Anova’s app to connect is what worked for me.

This is what people need to understand. There was not a single setting change in my network environment or on my android device other than a simple password change and forcing a sync.

You must be kidding me. Do you really expect a typical home cook to understand all the network gobbledy-gook below? Most people use their routers with all the default settings and would never know how to start to set any of these. If you want to see what a good consumer experience looks like for a wifi device, go get yourself a Google wifi and go thru the setup. It never asks you about IP addresses, NAT translation, or anything else that only a network admin would understand. But don’t expect it to work with your Anova device, because the Anova isn’t capable enough to work with a network that combines the 2.4GHz and 5GHz bands into a single network and frequency hops (automatically) to optimize your experience. Please re-think what you expect your typical cook to understand about their network.

I have news for you! This community is Anova customers helping Anova customers. None of us had a hand in deciding what Anova did with their selection of components for their units.
I’d suggest a little more familiarization with a community before you start blasting people for helping out.

1 Like

This forum is hosted on the Anova website. Given that, I think it’s entirely reasonable for me to assume that Anova support monitors the forum. And I think any reasonable reader would realize that my criticism was directed at the design of the device, and not the people that are trying to help overcome their poor design.
I’m sorry if you took personal offense from my post.

Quoting someone is basically a reply. Pretty basic forum etiquette.

Hi @Dvnorton

At one time your assumption that Anova support monitors the forum would have been a good one. Sadly, this is no longer true. You can get some knowledgeable feedback from other users here as well as sympathy from others who may suffer from certain problems, but it’s all users and no Anova here.
That said, there are a lot of users that can give useful advice so it’s a pretty good place to start for most questions!