Wont Connect!!!!

I had issues out of the box trying to connect my Anova Precision Cooker Wi-Fi, as well as the Robot vacuum my brother gave me. After downloading the App and going through the setup process the app would not authenticate the Wi-Fi password after making a successful handshake to the home Wi-Fi network. Enter 4 digit code fron cooker+ successful,
My Configuration:
1.) Anova Precision Sous Vide Cooker WiFI Only “new version”.
2.) Kyocera Phone Android 7.1.2
3.) Samsung Tablet Android 10.1
4.) Router Netgear R7000
The list of things I tried were:
1.) Removing and reinstalling the Anova APP…. No Fix
2.) Hard Reset on Home Wi-Fi reconfigured to only broadcast 2.4ghz.
3.) Cleared Cache and Data from Anova App on Android.
Here is what finally worked and why:
1.) Place wireless device into airplane mode.
2.) Enable Wi-Fi (Airplane mode will shut it off so you need to turn it back on) this will ensure you only have Wi-Fi for connectivity.
3.) Proceed with setup instructions as usual.
Why:
Some wireless devices (Phones, Tablets) want to give a priority override to wireless cell network for data vs instead of the Wi-Fi Network. This seems to be Wireless Carrier specific as well as root software specific in some devices. I worked for AT&T Wireless for 17 years and I cant believe I didn’t remember this. In Short the connection of your device generates “revenue” on a cellular data connection, not wifi, so that is why they pre-program the override on the cellular data network. In closing I was also able to connect my Shark Robot Vacum and my Thermostat after discovering this. I hop this helps anyone having the same issue as I did.

Nicely stated concise work around, thanks, I too have “wavering” connectivity with my original Anova.

Well, the APC likely still has the same shortcomings that:

1). Only 2.4GHz (disable the 5GHz radio if using the same SSID during initial setup)
2). Wifi password has to be 19 characters or less
3). No spaces in your wifi password