Extending past 99.5 mins

How do I set unit for 36 hrs and walk away? The max time is 99-mins. Can I toggle somewhere to hours instead of mins.?

That’s actually 99 hours, not 99 minutes. Each increment of the timer is 5 minutes.

Well, something is goofy about how the timer works. I just got mine, set it up, put in some chicken. Use only the app to set the temp and time. I did get a notification when the water was ready. Had my timer set for “2:0” which you’d figure is 2 hours. Right? Wrong.
Checked back about half an hour later, the cooker was off, temp was down to 147, and the time had expired. So… that’s stupid.

The last time I used the timer, it did not turn off the cooker, it just made it beep, I didn’t even get a notification (they’ve never worked for me with the Wifi model).

But in the cooks I did this weekend, the cooker would turn itself of for no apparent reason - even though I had not even set a timer!!! - so maybe that’s what happened to you - not that you set the wrong time.

I suspect it’s Anova’s servers that are acting up again, which is a big problem IMO - it’s fine to have a connected cooker, but if that means it’s susceptible to server problems they have built a very bad infrastructure. The cook should NEVER be influenced if there are server problems - it most it should not be possible to change the cooker via WIFI - but it should NEVER CHANGE anything on your device without you knowing it.

I’m hoping someone from Anova sheds some light in this, here or in the thread I started: