Fill water tank indicator with full water tank

My brand new APO is asking me to fill the water tank when I try to use the steam function, but the water tank is already full! I’ve tried to reinstall the water tank a couple of times but it keeps asking me to fill the water tank. The steam function initially worked after I received the oven but broke down on the third day when I wanted to bake bread :frowning:

Anyone else had this issue?

1 Like

I have the exact same issue. Got my oven today. Extremely disappointed given the price.

Are you still having this issue?

Had the same issue. There is a indicator on the led bar/handle. Push this and the problem is gone

APO owners should consider the engineering and technology they have for such a low price.

A Miele steam oven costs about $4,600 and the similar size of commercial Rational Combi-oven costs $11,300.

Actually that wasn’t my fix.

Touching the icon would make the error go away but it kept coming back 5 to 10 minutes later.

I did this like 8 times and it was driving me nuts.

Finally, what fixed it for me was I had to slide my water tank back and forth slightly so that the white release plunger at the bottom would move in and out.

I did this until there were no more bubbles and I haven’t gotten the indicator icon yet again.

1 Like

Ive tried moving the tank as suggested. Have tried to turn sous vide off and make it 100 degrees and 100% steam ut still asks me to fill tank when its full

For anyone receiving this message, firstly try the suggestions here:

If the above doesn’t work, run the descale program with plain water, this is what resolved the issue for me.