Interesting finding for Wi-Fi problem

I just got my Anova Precision Cooker (new 2019 version) today.
I had severe problems to get it connected to my Wi-Fi network.

The problem was that my 2.4 GHz network didn’t show up in the list of available networks in the step after entering the 4-digit code.

I tried to see if there were any problem attaching one of my PCs to the 2.4Ghz network instead of the usual 5Gz. The network didn’t show up here either!

After some troubleshooting I tried to change my channel settings from channel 12 to channel 6 in the router. Now I was able to connect the PC and succeded to connect the Anova to WiFi also!

I have a ASUS RT-AC68U router.

Is this a known issue or limitation regarding supported channels?

The Anova models have had issues with WiFi connections for years, and you can find plenty of other discussions about that in the forums. If your WiFi connection isn’t very strong due to distance or interference, it won’t connect or will drop the connection. In your case, you probably have more interference on channel 12, which is why switching to channel 6 allowed it to connect.

In any regard, the benefits of WiFi for the Anova are pretty limited. I never use the WiFi and I think that after you get used to cooking with the Anova for a while, you won’t either.


In my case it was really the opposite. Channel 12 (and 13) at the edge didn’t have that much interference compared to the middle channels like 6. I did some measurements.

Channel 12-14 are not legal channels in the US, i.e. only available in Europe?
Could that be the reason?

Tried holding the cooker beside the router without any success.

When searching the community for similar problems I didn’t find anything similar. Feedback from Anova support didn’t propose changing channel as something to test either.

Now I am up and running and it seem to work several days in a row.

I know that the WiFi feature isn’t offering that much benefits if you are at home.
The only reason for using it when at home would be to set the timer to any value (minute level )resolution), e.g. in cases where 12 min makes a difference compared to 15 min.

I tried forever to get a connection, had no luck with tech support, and they did a warranty exchange with me. Same problem with a brand new unit. I finally found a tip somewhere that told me to reset my network to 2.4ghz, then login into a dedicated network, so I used my guest network, not my regular one. Bingo, it finally worked. Then I reset my network to 5ghz and have no problems.

I have to say, Anova support was CLUELESS and put the blame on me, not on their shoddy designers. You’d think they would do a firmware update to make things work. Had I had any idea how much frustration I would have with the unit and tech support, I would have bought a Joule without hesitation.

Once it’s set, it does work well, though.

Thanks for the tip, that could be useful for some

@amkaplan Do you see your network in the list of available networks after entering the code?

Support confirms that Anova Precision Cooker (2019) only supports channels 1-11.

This explains my problems!
Channels 12-14 are used in Europe where I live.

This should be added to wifi troubleshooting guidelines

I too had this problem connecting to Wi-Fi but I’m not that technologically familiar with changing channels I don’t router. I Purchased mine the end of April and returned it three weeks later for a refund. However I missed having yet and I saw that Amazon had it on sale for $149 which I thought was a much better price point with the fact that the Wi-Fi needed such technol wizardry to connect. So I ordered it again at $149 it cooks great techno stuff needs lots of work. I will just ignore the fact it doesn’t have Wi-Fi that is user-friendly.