My experiences after a few weeks

I received my cooker and have made some interesting and delicious meals with it. Below are my impressions.

The immersion heater itself works, and is accurate. Measuring with four other thermometers (one of them a high-precision digital one), temperature readings were accurate to 0.3 C.

Problem with the unit itself: it stinks. Literally. The instant I opened the box, the room filled with an acrid smell, reminiscent of burning plastic or overheating electrical insulation. This wasn’t just a strong smell; it was a smell that filled the house. The smell comes from the rubberised covering on the handle. That’s a nice grippy surface that looks good, but smells terrible. I’ve kept the unit outside in the sun for the past two weeks. It’s still too smelly to take back inside. (And, no, I’m not fuzzy about things that smell a little.)

The clear/transparent plastic cap that is supposed to be removable at the bottom of the unit cannot be removed. (No, I’m am not trying to turn it in the wrong direction.) No matter how hard I grip (with towel and without), it will not budge. (Yes, I watched the support video of how to do it. The cap will not move, period.) If I were to try any harder, I’d have to use pliers, and would possibly break the cap or bend the tube, which I don’t want to risk.

The iPhone app is unreliable. Pairing was easy and worked on the first attempt. But the bluetooth connectivity is dodgy. If the phone goes to sleep and wakes up later, the app frequently can’t re-establish communication with the cooker. Sometimes, killing the app and re-starting it fixes that problem. Other times, it doesn’t. On the up-side, the connectivity loss doesn’t affect the settings on the cooker, so it keeps maintaining temperature and the timer. On the down-side, it makes the app useless if this happens (and it happens often). To get the app to talk to the device again, you have to power-cycle the device.

On one occasion, the app decided that cooking was done and started beeping after about 3 hours into a 48-hour timer setting. It simply decided that it was time to stop the cooker. No idea why. My phone was just sitting there doing nothing special when the app beeped and told me that cooking was done. I ended up subtracting the elapsed time from the total cooking time, reset the timer and basically restarted the whole thing, which got me to my desired 48 hours of cooking.

Overall, I’m disappointed. The Anova is a nice device, but with lots of hastily put-together things that should have been left out. The iPhone app (I didn’t try the Android one) doesn’t work reliably enough. Manually operating the device without the app (if I can manage to find out how, because it’s not documented) would be preferable to an app that doesn’t work some of the time.

The stuck plastic cap is annoying. I can remove the entire stainless steel tube for cleaning, but I cannot remove the plastic cap to get into the tube from both ends and for cleaning the cap itself.

The stink of the plastic on the cooker is extreme. I expect that it will eventually dissipate but, until it does, it’s not possible to keep the unit inside without everyone who walks into a (large) open space immediately commenting on whether you have something burning. (I had four separate people say exactly that.)

So, yes, it works. I’ve cooked some nice sous vide with it (outside). The app sucks, the plastic stinks, the documentation for how to operate the thing without the app is practically non-existent, and the stuck cap indicates poor quality control.

It’s an average device that does an average (and not very complicated job). I’ll keep it, because I can make it work and live with the flaws. But I expected better.

2 Likes

Hey @michihenning appreciate all that you’ve written here.

I am really concerned about your cooker giving off a burning smell. That’s not supposed to happen at all. I would let customer success know about that issue, so they can go right ahead with exchanging your cooker. It shouldn’t emit any smells (unless it’s something delicious being cooked). :wink:

The cap can be a little bit of a stubborn one to budge. Takes a bit of oomf. Not long ago @Ember gave really helpful tips here in the community that’ll help with removing the cap. Check out this thread: Removing plastic end cap

As for the app - something is obviously not right. Not sure what exactly is going on here, but customer success can also help with troubleshooting the issue and getting you a resolution.

This feedback is super helpful - I will be forwarding this to the rest of the team. Thank you so much!

-Alyssa

1 Like

Fortunately I’ve had nothing but good experiences with the machine. I hope you contacted customer service because through no fault of theirs I lost a piece from the clamp that fell off. They responded by replacing the whole clamp. They have great customer service. I have read reviews where others have praised their customer service. They certainly didn’t disappoint.

Anyway, all of what you say seems unusual. I would contact them and see what could be done.

If there’s any wish that would improve the machine, I wish the heating unit was stronger. Even with hot tap water which is about 110 degrees it takes 10-15 min to heat up to 135 or so and another 15-20 minutes to go to 185. I suppose I could just heat up the water on the stove and I might just do that in the future if the waiting time starts to get in the way.

All in all though, I’m very happy with my Anova.

As for my cooking results? The straight heating things, like steaks and corn come out terrific, as for other more intricate recipes, well, this isn’t magic it still does take some skill, which I still lack, but Anova (sous vide) gives you a nice elevated jump off point. It can only get better with experience.

Of which handle are you speaking? The Anova cookers don’t have “handles”, per se. Are you referring to the control unit (top black part)?

I’m referring to the black rubber-like coating on the top half of the unit. It emits a sulphurous smell (similar to match heads), reminiscent of electrical insulation that is overheating. The smell comes from the material itself. It was evident immediately when I opened the box, before I ever plugged it in.

I suspect that the smell is from plastic softeners that are out-gassing. I’ve had the unit outside in the air since I bought it. The smell is gradually getting less, but only very slowly. Last night, my wife immediately complained that I’m using the Anova again, because she hates the smell. I can smell it quite strongly, too.

I tried heating the steel tube with hot water and wore a rubber glove to get a better grip on the end cap. No joy, it won’t budge, even with all my strength. (I am man, and not of slight build…)

Smell is still lingering, enough for my wife to demand that I don’t use the Anova in the kitchen and do my cooking outside.

Last night, I had the cooker doing it’s thing on a timer. The timer expired, the Anova did its “three-beep” thing to let me know that it’s done, and the iPhone app correctly told me that cooking is finished. I was sitting at the table at the time and decided to let things cook for another 15 minutes or so because I still had some other things in the oven that weren’t ready yet.

Boyoh, was I in for an experience. The Anova kept doing its three beeps every few seconds, and nothing I did on the phone app managed to stop it. The beeps just kept coming. I figured “OK, I’ll just start another cook at the same temperature with a 15-minute timer, so it restarts, that should stop the beeps.” Nope, it didn’t. Anova still beeping.

Eventually I walked over to the Anova and fiddled with the touch controls. That stopped the beeps. And, man, the UI for the touch controls is a complete design fail. Not being able to change the timer without changing between Fahrenheit and Celsius? Really? Whoever came up with this was clueless. The one thing that people will set only once and never again is the temperature unit. The one thing that they will want to change all the time is the timer. Yet, to change the timer, I need to press and hold for eight seconds, and to change the unit, I need to press and hold three seconds? Hello? Especially seeing that the timer setting cannot be reached without also changing the unit? The sensible thing would have been to require a three-second press to reach the timer, and an eight-second press to change the unit.

I noticed that there was an update for the Anova app for the iPhone this morning. The explanations for what was changed were singularly unhelpful. Is it possible to get a description of what (if anything) has changed with respect to operating the unit? Is it possible again to calibrate the unit, or is that still disabled?

I’ll contact customer service today and see whether they’ll exchange it. The combination of the smell and the locked-on end cap is a little too much for me to just let it slide. Hopefully, it’ll be possible to get one that doesn’t smell.

2 Likes

I had to chime in when I read that you experienced an acrid smell that filled the house… instant that you opened the box.
That has not been my experience. No bad smells.

I have been monitoring this forum since I first got mine a few months ago, and that is the first that I have read. I am really interested in the reason.

I don’t believe I’m the only one experiencing this.


https://www.ozbargain.com.au/node/278656
https://www.amazon.ca/gp/customer-reviews/R2ZV5880J9XLC9/ref=cm_cr_arp_d_rvw_ttl?ie=UTF8&ASIN=B00UKPBXM4

So, there are a few other people with this issue. But it doesn’t look like it’s a widespread problem, otherwise there’d be many more such reports.

I’d like to keep using the cooker. I’ve contacted customer support, and I’m hoping that they can come up with one that doesn’t smell.

1 Like

Yes I see others also. Weird indeed.

I can’t help but wonder if they all came from the same batch and there’s a problem with the formulation of the plastic used.

Rubber and sulfur (vulcanizing the rubber to make it durable) makes sense but shouldn’t emit odors.

I only use the cooker in manual mode.

I just receive an email from Anova support. They are sending me a replacement unit. I’m not required to send the existing one back; instead, I was asked to take it to an e-waste centre and to provide a photo of the receipt.

I have no idea whether they hand out receipts for something as small as this; it’s a giant government waste facility. I guess I can always take a selfie with me and my old Anova in front of giant pile of electronics gear that’s about to be scrapped :slight_smile:

Full marks for Anova customer support! That was a very fast and unbureaucratic way of addressing my problem.

Fingers crossed that the next one won’t smell… :slight_smile:

2 Likes

I’m glad it all worked out! Keep us posted about the next unit you get. :slight_smile:

I received the replacement cooker today.

The new unit has no smell. I can’t smell a thing unless I stick my nose right against the black portion but, even then, it just smells vaguely of rubber and plastic, whereas the smell from the previous one filled the room. So, all good, totally happy with that.

The plastic cap on the replacement unit was removable with some effort (and rubber gloves). After getting it off, I locked and re-opened the cap a few times, and now it moves a bit more easily, so I can deal with it without putting on gloves. Again, all good, I’m totally happy with that. (I also went back to the original unit and tried again to remove the plastic cap and, no matter how hard I try, I still can’t budge it.)

I have to say that my support experience has been very positive. I received the replacement quickly and without fuzz, no questions asked.

BTW, just for fun, I placed both the old and new unit into the same pot of water, set them both to the same temperature, and turned both of them on. The reading for the actual temperature on the two units is identical. No disagreement at all, not even to 0.1 degrees Celsius. It appears that the thermometers are very precise.

3 Likes

Yay! I am glad it all worked out. Yeah, that smell problem was totally not a normal thing. And it looks like this unit you have now doesn’t have a stubborn plastic cap like the the old unit you had. That’s good.

Awesome!

:heart_eyes:

You are almost certainly trying to unscrew the end cap in the wrong direction. They are designed with threads in the opposite direction to the sleeve. This is so that you can unscrew them without also unscrewing the sleeve. The caps take very little pressure to unscrew and the natural tendency is to attempt to unscrew them in the same direction that you just unscrewed the sleeve.

it’s a bit like a Chinese finger trap: to release you have to do the opposite of what your instincts are telling you.

It’s not really necessary to even think about what direction is the correct one: just grip the sleeve in the left-hand and use moderate pressure on the end cap in alternate directions. as you twist in the wrong direction nothing will happen and as you twist in the correct direction it will readily release.

The design of the grip is such that they cannot be over tightened. This is a case of very good design with less than optimal communication.

the best solution would be to both note in the instructions that the sleeve and end cap screw in opposite directions and to put an “<- on off ->” on both the sleeve and the end cap.

PS I’ve only worked with mine cold (because I haven’t yet been able to overcome the low water alarm going off immediately and preventing both the circulator and heating element working (or maybe one of them is defective and that causes the LWA to go off). So maybe the end caps do become difficult to take off when the unit is hot (due to expansion of the stainless steel sleeve).

I just got my WIFI Anova last night and I had the same issue.

As soon as I opened the box I smelled this STRONG chemical odor.

The odor was so strong that it gave me a faint headache.

I promptly put it back in the box and went to bed, not wanting the headache to get any worse.

This morning I woke smelling the same smell then I realized that it was my hands that is smelling like that. I tried washing my hands using my usual Softsoap (many times) and my hands still reeks of the chemical smell.

Right now I have the Anova unit out in the back yard to air out. Not sure if it will do any good but there is NO WAY I am letting that near my food smelling like that.

I called customer service and the CS agent told me that it is normal to have some smell and if I want I should return it to Amazon for a replacement. My problem with that is by returning it to Amazon there is no guarantee that the replacement will not have the same issue.

This is my first Anova product and this is not a good start.

It seems you didn’t read my follow-up post:

So, I am not only almost, but completely certain that I was trying to unscrew the end cap in the correct direction.

the endcap screws off in the opposite direction as the sleeve. There is a good reason for this as it ensures that if you are trying to remove only the endcap you don’t take the sleeve off with it, but IMHO, ANOVA should make this more clear in the instructions and video and possibly Mark both the sleeve and the endcap with the appropriate directions ("<-on off->")

The design is excellent, IMHO, in that it makes it impossible to over tighten either one.

If confused about which direction to turn, just twist it back and forth. as long as one hand is holding the sleeve and the other is holding the display when trying to remove the sleeve, or the endcap when try remove the endcap twisting it in the wrong direction will have no effect and will not further tighten what you are trying to release.

When cold, both the sleeve and the end cap release with very moderate pressure. It may be more difficult release at high temperatures due to the stainless steel expanding. The solution for that would probably be just running cold water over the stainless steel (but of course not the display section!) For a few seconds.