No action from my anova :(

Got an Anova as a gift over the holidays. Was super excited to try it out.

  1. Filled a pot with water
  2. Affixed the clamp to the pot
  3. Placed the Anova in the clamp and tightened
  4. Plugged into the wall outlet… and…

Nothing. No activity from the device. No information on the LED display.

Tried a few other wall outlets, same outcome.

Any ideas? Hoping the unit isn’t defective.

If it’s not turning on at all - it sounds like it’s dead? Have you also checked if the outlet works for other appliances?

Hi AlyssaWOAH,

Yeah, tried 5 different outlets… no action. The same outlets seem to be working with everything else.

My hunch is that’s totally out cold. :frowning: But support can still help you out with this issue. I’d reach out to them.

Tried reaching out… CRICKETS…

What was your support ticket number?



Thank you! Just pulled up your ticket - see you emailed us yesterday. It typically takes 24-48 hours for a response, especially around the holidays/high volume. But I will ping our team. We’ll have someone follow up on your ticket. :slight_smile: