Anova customer service

I’ve been trying to get a response from customer service since my oven arrived in mid december. The oven will not connect to wifi, so its working but I can’t use the app.

I called twice and both times no one answered, instead I left a message. No one has ever called me back.

I emailed three times. They answered my first question (about when my oven would ship) after it arrived. They answered my second email about connectivity and then closed the ticket the same day when I didn’t immediately respond. I emailed back and haven’t heard from anyone.

Anova is advertising to me the red carpet service that comes with the oven. I’m not seeing that at all.

Anyone out there getting a response from Anova?

This is deeply weird, because I got a decently-timed response (given COVID and holidays). I’d resend your request for help through the the Support link.

Customer service is extremely backed up. They sold way more ovens than they expected. It is taking between 1 to 2 weeks to get responses. For the WiFi issue, if you use a VPN on your phone or tablet, disconnect it. That has been the most common issue. If you use an adblocking DNS service like adguard or nextdns disable it during setup. Also check if you have something like parental controls turned on in your router. You may need to write a rule for the oven to bypass the rules. If it isn’t one of those, then yeah, you probably need customer support. If you are a facebook user, there are two active groups, and at least one Anova employee participates and may have more ideas. #anovafoodnerd fam - sous vide and combi oven cooking and Anova Precision Oven Cooking

I emailed and got a call without issue.

They seen to be MIA there. I ordered my APO on Dec 31st. This morning I received a full refund, with no explanation. I tried to contact them three different ways, phone, email and online chat…no response…I wanted to see that my APO had shipped, not that the order was closed and refunded with no apparent explanation. Guess they don’t want my business???

1 Like

I’ve had excellent service from Anova Support since receiving my APO at the beginning of November. Initially I had some minor questions and they were answered promptly, including some follow ups. Then, a couple of weeks ago, I experienced some issues with how the steam process was working. Sadly, after a few back and forth messages with Support, we concluded the oven was malfunctioning and needed to be replaced. I was immediately provided with a UPS shipping return label to send my oven back, which I did yesterday. (Fortunately, I kept the box and styrofoam - DON’T throw it away if you’re a new purchaser!) I’m now waiting for a new oven and I’m hoping it won’t take too long because I miss it already! Perhaps the Support response varies depending on location? I’m in BC, Canada and dealing with Support in Ontario, Canada. The message from Raptorman who reports getting an unrequested full refund instead of shipping details seems very strange indeed! As for the WiFi issues, it’s unfortunate that potential help from other APO owners is scattered all over the place, but that seems to be the case. I would prefer to have everyone use this forum, but it seems more people use Reddit (which I find tricky to navigate) and Facebook, which I don’t use at all. I agree with other comments here that the best approach is to continue trying to reach Support through their normal channels. For me, email has been fine. Now that the holidays are over we can only hope Anova will be able to step up to servicing what appears to be a VERY successful runout of their new oven!

1 Like

Hey, thanks for sharing your experience. I’m also in Canada (Halifax) I think that I may just go ahead and re-order, but I was hoping to speak to someone to ensure this wouldn’t happen again. For the last week I was thinking that it would ship and wouldn’t be long before it arrived, and then I was refunded…I don’t get it…and frustrating that I can’t speak to someone, but I guess they’re overwhelmed from what I understand…

I used email support. It was taking them 2 to 4 days to respond to the newly opened ticket (due to backlog I am sure), but after the first one, the responses were very quick (probably part of their KPI). I was usually the slow one, the system closed the ticket when I did not respond in several days. Received my replacement oven just fine.
Happy with the oven, happy with the support. I am in east coast USA, I have no clue where support folks are located.

@hairgeek at what point does it fail to connect? Are you able to connect your phone to the oven and choose the network & password?

Make sure that you are not trying to connect to a 5gHz WiFi. Many “WiFi enabled” household items will only connect to 2.4gHz networks. Access your WiFi router, temporarily turn off your 5ghz network if it exists, and try again.

No oven and no reply. Over a month since ordering and 10 days past supposed delivery date. No response to inquiries. No customer service.

The app only works on one phone, so if you downloaded the app to multiple phones that is your first issue. Next, you can “reset” your oven and then try to reconnect to the app. To reset the oven Hold the Far left button and the Far right button for at least 5 seconds. You will hear the system reboot.
I too had a difficult time getting hold of anyone from Anova. I posted on FaceBook, reached out by pm on Facebook, send emails, reached out by the robot chat on the website, made many calls and nada… Silence.

There was some discussion on this a while back.

My recollection is that a few of us concluded that:

  • The Anova oven does indeed only support 2.4 GHz Wi-Fi, not 5 GHz or (the too new) Wi-Fi 6E. That’s typical of home appliances (same for our smart thermostat).

  • The Anova oven’s Wi-Fi support seems to use the obsolete WPA protocol. That’s a real problem since many recent Wi-Fi routers no longer support the original WPA for security, but instead support only WPA2 and/or WPA3.

  • That WPA problem impacted our oven install; luckily I had an older Wi-Fi router I could use specifically for this purpose.

  • I don’t think we have received official confirmation of the above one way or another from the Anova support team.

Hope that helps!

Turn off mobile data when trying to get the oven to connect, many phones will automatically connect to the network and interfere with your connecting.
My oven connected right away and even connected to my 5G mesh wifi

we finally got connected by using an ipad to connect and then it worked on the android phone. Had tried all sorts of things before that.

My wifi worked seamlessly until 3 days ago. Now the oven won’t connect to the app. Any ideas on what to do?

I agree with other comments here that the best approach is to continue trying to reach Support through their normal channels.