Oven: Hour 1 observations

I received our oven today and ran through the initial setup. I have a few observations that stood out as minor annoyances:

  • The light flickers when the oven is heating. This is clearly an electronics problem with the oven since it’s an incandescent bulb.
  • The timer as used on the device doesn’t seem to turn off the device at the end of time. That is counter to how we have all been trained with some devices like Microwaves and our Breville ovens. Maybe this works differently with the app. I don’t know yet. Haven’t gotten there.
  • Smells awful. I’m sure this will go away, but its seriously like a Styrofoam factory smell.
  • There was water in the unit when I took it out of the box. I assume this is from testing, but its weird.
  • There is no obvious ON indicator other than maybe the inside light. The OFF for the steam setting is confusing since looking across the room you see OFF, but nothing on the handle to give you a huge indication the oven is on. If the bulb burns out I’m not sure what is telling you its on.
  • There is a temp target indicator and what the current temp is when the oven is ON, but when the oven is not heating there is nothing telling you the internal temp.
  • The manual is too vague on what types of cleaning supplies you can use.
  • The manual isn’t upfront about recommending distilled water for the tank or what specific descaler product to use. All of my other steam based products are overly specific on the products to use to ensure there is no damage…like my superautomatic espresso machine. I’ll probably just use our RO water and descale monthly. I don’t feel like buying jugs of distilled water.
  • I think it looks nice and I feel its well built. If they offer a different housing in the future I’d upgrade. Not super in love with basic black paint. I like the new Breville colors and of course stainless and black stainless etc. The basic black is fine, but now I know I’d pay more for a finer look for something that is anchoring my counter.

I know this seems like a bunch of negative stuff, but I’m still pleased with it. I’m an early adopter type and hope the feedback translates into change.

App:

So far I can’t get it past the login screen. It freezes on a white screen. Uninstalled and reinstalled etc etc. No workie.

Two different android phones have the same problem.

I have the same flickering light issue with my oven. I assume this is a fault and not a ‘feature’.

Yes, it seems to correlate directly with the power draw for the heating elements cycling and slowing to hit the temp target. PID hitting the SSR maybe. Maybe they needed and SSVR, but the cost was too high. Just totally guessing.

Not sure we will see a fix for it since it’s more than likely a hardware deficit. I hope I find the ability to control the light in the app when I get it working. I’d just turn it off most of the time. The flicker is too much.

I finally got into the app and updated the firmware on the oven etc.

Sadly, there is no way to turn off the light from the app.

Just got mine and tried it for the first time last night. I got a lot of steam coming from the bottom of the oven instead of the vents on top. Is this normal?

My experience so far

  • installed the oven app and logged in with Google OK before the oven was even close to arriving
  • light flickers, slightly annoying
  • when oven is on, rightmost icon seems to change slightly (to play triangle icon) and oven temp appears to show internal (with fluctuations)
  • timer zero does not appear to shut off oven? That seems unexpected/wrong - might be worth reconsidering
  • haven’t gotten it to connect to WiFi yet- keeps failing after entering network credentials

Update 1

  • I think that at least the original firmware is trying to connect to WiFi with WPA (not WPA2 or WPA3) which is why it won’t connect to some access points! I was able to connect the oven to a different network/router that supports original WPA, and then it appears to rendezvous through the cloud - and my phone can be connected to whatever network it likes.
  • After connecting- firmware updated to 1.0.1; when oven is on, the play icon now turns blue
  • Cooking still does not appear to stop when time is up, but you can stop remotely via the app which will notify you.

I also noticed a very faint warm color for the triangle when the oven is off on 1.0.1. It’s doing some sort of pwm so I can catch a flash of red when moving a glance quickly to trick the brain. I don’t think I’m imagining it.

I’m not totally sure what’s going on with the wifi. I had a hard time also, but it worked to my Ubiquiti wifi (that isn’t running WPA), but only from one of my phones. The others failed.

Glad at least one other person thinks the timer should shut off the oven.

@mach
I only have WPA2 enabled but could connect with the factory installed firmware before the update - my oven could not connect to any 5Ghz networks and I had to use a 2.4Ghz network instead.

Thanks - that’s interesting, not sure if it’s worth me trying to change the oven’s network settings now though. I don’t think the oven does 5GHz Wi-Fi but yeah 2.4 GHz seems good