Skirt locking function

Hi all, I’ve noticed now that I’ve taken the stainless steel skirt off the unit a few times that it’s quite loose in the “arrows aligned” position. When the unit is clamped by the skirt in a smaller pot (as opposed to clamped to the black body of the cooker), I can easily turn the body of the unit about 1/8th of a turn until I start to feel some friction. When it was new the skirt was fitted quite firm and required a decent effort to rotate it from the body. Has anyone else experienced this, and @"Stephen Svajian"‌, has there been any change to the design of the skirt lock in the production units? If not, this could be a potential problem once the plastic mount for the skirt wears down a bit.

hi @Angela‌ , just wanted to see if you had seen my comments above?

I’ve had the same problem. Mine is completely loose when in the locked position and the impeller occasionally rubs the sides of the housing if I am not careful. Have you found a temporary fix?

No, I’ve just been careful with it. I suspect a few of the device failures that have been reported on here are this same problem with the impeller touching the skirt and grinding or stopping completely then throwing an error. Either way, Anova don’t seem to think it’s worthy of any attention.

@aarthur‌ Do you have a dev unit? If that’s the case, then yes, we’ve made changes. Could you take a short video? If that’s too much, no worries, but that would be super helpful. Thanks.

If this is an issue for anyone, please submit a return request here: http://anovaculinary.com/pages/returns

yes, I do have a dev unit. Thanks for clarifying that this has been fixed.

Just got my units and I don’t like the skirt clamping method. Like yours it starts out almost too stiff and I can see it eating the plastic away until it gets loose. Only time will tell…

I’ve only used my unit 7-8 times and the skirt is definitely loose now. Skirt lock started out firm/stiff (though not too stiff) but is quite loose now. I do not have a dev unit.

@celltech‌ @_G_‌ Please submit return requests here: http://anovaculinary.com/pages/returns.

@Stephen Why should we submit return requests? What is any different with a new unit?

Just get a new one every 7 - 8 cooks!

I have the same issue with my developer unit. However, it gets loose only if i tighten it all the way. If tightened half way (say 30%-90%) it is still nice and firm.

@Stephen‌, already submitted (but I haven’t received a reply yet). What is the issue with production units though? Should I expect that every 7-8 uses I’ll need to replace my unit?

I’ve got the opposite problem, I can’t get the thing back on! I assume the divots are supposed to slide to the right down those plastic channels? Anyone got any advice? I can’t get them past the start without it feeling like I’m going to snap something.

I've got the opposite problem, I can't get the thing back on! I assume the divots are supposed to slide to the right down those plastic channels? Anyone got any advice? I can't get them past the start without it feeling like I'm going to snap something.

Make sure the impeller is making it through the round opening at the bottom of the skirt, it will hinder progress if things aren’t lined up properly down there.

Make sure the impeller is making it through the round opening at the bottom of the skirt, it will hinder progress if things aren’t lined up properly down there.

I was expecting the little nub thing to slide all the way over to the circle, but it seems like they just dig in to the opening of the plastic channel regardless. It’s been working alright like that, so I assume that’s how it’s supposed to be. Yeah the impeller thing is a bit of a mess around, but I won’t be taking it apart very often anyway so I’ll just have to bear it in mind when I do. Cheers for the advice anyway