Temp goes up too high

Second time I’m using the BT sous vide.
I filled my container with preheated water. Turn on the sous vide and wait for the water to reach the desired 60’C temp. When preheating is done I put in the sealed bag and start coocking. After 45 min. the sous vide starts beeping. The temperature is 6 degrees above the desired temperature.
I dont think this is normal. What did I do wrong? Or is something wrong with my sous vide?

Waterlevel was fine.

Thanks in advance

Erik, just your second time.
Was your first use successful? Good, let’s try an understand what might have gone wrong.
On this second occasion did you set the temperature and time manually or remotely? I recommend you perform manual settings until you have confidence gained from several successful cooks.

You are embarking on a very different cooking method that above all requires a detail-oriented approach. To begin, sous vide is the commonly used name of the cooking technique you are attempting to use. Is sous vide also the name you’ve given your new Anova Precision Cooker?
I call mine Cosmo.

As i understand, you were cooking something at 60C and after 45 minutes your Anova sounded its intermittent finished signal, - not a steady tone, that’s its alarm.

Did you set your cooker’s timer for a 45-minute cook? You write “desired 60C temp.” Do you mean that was the precise temperature setting on your Anova cooker’s control interface?

At the end how did you know the water temperature was 66C?
Did you verify it with a thermometer?

Or was the actual water temperature (upper reading) on your Anova’s display 66C even though the set point temperature on the display at that time was 60C? (lower display reading)
As i understand the Anova’s operating system, that should be impossible.

What was the temperature of the “preheated water”?
Did you add more hot water during the cook?

I regret asking so many questions, but without a solid understanding of your experience with your new cooker it is difficult to assist you.

Dear Chatnoir,

Thank you very much for your reply. Really appriciated.
I’ll try to answer your questions…

-First time was fine

  • I’ve set the temp via the app, connected with bluetooth
  • You are correct… sous vide is the method, not the apparatus :wink:
  • I’ve set the temp to 60’C and timer 16 hours on the cooker, after 45 minutes cooking (after preheating the water from 52C to 60C), the temperature went up to 66C. I heard an intermittent alarm. The cooker did not stop working.
    So, the water was 6C higher than the temperature set on the cooker.

I think I already solved the problem. There was a bit of waterdamp on the wheel and air vents. I turned off the cooker.
Cleaned it and put aluminium foil tight around the cooker. (metal part of the cooker, not over the air vents…)

After that, the cooker worked as should be…Perfectly stable. I went to look at the cooker several times because on my phone the temperature was always 60,0, I thought the diplay freezed :slight_smile:

Meal was great!!

BTW I use a coolbox as a container. The outside of the coolbox stays cool, so I think the cooker doesn’t have to work as hard as when a non insulated container is used.

1 Like

I’m glad you were able to discover what went wrong and the solution. When adding product to your vessel immerse them gently so so water doesn’t splash onto or inside the Anova. Electronics don’t like to be wet.

1 Like

Thanks @chatnoir for helping out here.

1 Like

My pleasure, Alyssa.

I attempted to point out attention to detail is fundamental to successful cooking with the Anova, particularly for beginners.

1 Like


An old thread, but I just received my Anova Wifi+Bt today after a long wait and I’m having quite similar problems.

I have set the temperature and time from the app + I’ve tried setting the temperature straight from the device (I didn’t figure out whether I could set the timer from the device too).

I’ve set the desired temperature from about 58c to 64c (trying to cook chicken, which is pretty much going straight to garbage after this adventure). The temperature goes to 64c, beeps and then is fine for maybe minute or few minutes. Then it starts to sail from about 62c to 70c with unnatural speed. It can change 2 degrees in one minute. Up or down.

I’ve disconnected the device a couple of times. First time the current temp was 72c before disconnecting and the second time it was 68c. Plugged it back after maybe 10 secs and the device immediately says the current temp is about 58c.

Then configured the desired temp to 64c again and it rises slowly. Just now writing this it got past 64c without beeping, up to 64.8 and then one second later it is 68.4c. And while writing this sentence, it’s now at 72c.

There is enough water (not too much), nothing is blocking the device, the water is circulating nicely and so on.

Is this a faulty unit or what should I do?

It might be a faulty unit. I would definitely drop an email to support@anovaculinary.com regarding your cooker.