Three Beeps & Reseting of Power; Help Please

Today I had the intention of sous viding some carrots for myself. Knowing it can take the PC a while to get the water up to 85C I set the Anova and went about my day. I’m currently working through a cold and as a result took a 3 hour nap. When I woke my room mate informed me that the fuse blew a couple of times for the area where the Anova was functioning. Additionally that it was beeping three times, flickering, and would occasionally start then stop.

I checked to see if there was any damage, but other than some condensation built up on the lower black rubber part there was nothing. No water had come up close to any of the electrical elements.

I left it off for a bit, then tried again and the same thing happened. Blew the fuse again, three beeps, flickering on and off. I’ve since taken it out and am letting it sit somewhere to give it a rest. But not sure what I should do. I bought this in September of last year, have done one 24 hour cook at 60 C, and plenty of 85C veggie cooks. Never had this issue before.

Here are some pictures of the inclosure I have the inclosure:

Have you tried it on a different circuit?  The PC’s only drawing 800w, but if you have a circuit that’s maxed out, this could be making the difference - if the PC’s in a “brown out” scenario, then the performance is going to be flakey as it’s not getting enough juice.  (and, it could be hard on the unit in such a circumstance).

If you try it on a different circuit and the behaviour is still flakey, then the unit’s likely fried - I’d contact support at that point.

I haven’t yet, I will. It was the only item plugged in on that circuit, so I’d be shocked if that was the case. But, no harm in troubleshooting. Thanks for the reply.