1 yr old unit overheated water bath, now not functioning - anyone else had this happen?

Hey there,
I’ve been having a great time cooking with my Anova (2nd gen, Bluetooth/no wifi) until today. I set it up manually to cook - 1 hour, 145F. It started up okay, I checked to see if the timer was running, and left it alone.

When I came back toward the end of the hour, I was horrified to find that the unit readout thought the current water temp was -17F (?!? Really?!) and so the heater was going full blast. I stuck my thermapen in and found the actual water temp was 224F! So much for my chicken.

I unplugged the unit and left it alone for a few hours. Went back to check its status a few hours later.

When I turned the unit on, I asked it to cook at 110F for 40 min. It tried to heat up, hat gave up after about 30 seconds. I tried it again once or twice, but it gave up increasingly quicker. Took a Youtube video of the event:

I’m really quite disappointed; although I bought the unit in mid-Dec of 2015, I didn’t start using it until March of 2016, so from a usage standpoint, it’s only been active about one year. (Don’t you hate it when something dies just out of warranty? It feels like a planned obsolescence plot.) Anyone else have a similarly unfortunate experience? Dropped a line to customer service, waiting for them to get back to me.


@ATB so sorry to hear! Thank you for reaching out to support - we’ll see what we can do for you!

1 Like