Anova One shutting off with "Low Liquid" Warning

I’ve only had this since July when Amazon was running a sale and it worked great the first four times I’ve used it but lately it’s been shutting off on its own with a “Low Liquid” warning.


The past couple times I’ve tried to use it, this has happened within a couple minutes of starting it. However, I read that the water sensor works by detecting ions and tried it in a vinegar solution. It worked so I added vinegar to the water bath and it got up to temperature and circulated the water for a couple hours.

It shut off again with the “Low Liquid” warning. When I tried to restart it, it worked but for about a minute. This time, there were some clicking noises preceding shut off. The fan was running pretty strong after shut-off so I have a feeling it is an overheating issue. Sitting in a heated vinegar solution should have descaled it thoroughly and I can’t imagine that doing any favors corrosion wise to the water level sensor. The fuse looks fine though that could be it. Apparently only the 230V units have a spare. What type of fuse should I get? Is there new firmware? Is there any way to bypass the water level logic?

I’m beyond the 30-day return period for Amazon so does anyone have suggestions?

Thanks!

@JordanV sounds like an Anova 1 - is that the case? Either way, head over to http://anovaculinary.com/pages/returns/ and fill out the requested info. From there our support team will help you out! :slight_smile:

Okay, I filed the return request. 


I’m hoping I can get another Anova One since that has higher reviews on Amazon and better specifications. It looks to be discontinued though.