APC Pro cannot connect to app after software update.

I have a new APC Pro and when I follow the instructions on the app, the software upgrade seems to take. But it never returns to normal and I can’t get the four-digit code to show so I can connect the app to it. My phone OS is android and it connects initially, but forces me to upgrade the software of the unit and that is where things go quickly downhill.
Any suggestions!
I have contacted support@anovaculinary.com

I am having the EXACT same issue. I recently purchased the APC Pro from Amazon during Black Friday and exchanged my first APC Pro for another believing I had a faulty product for some reason. However, my second APC Pro is having the same issue as the first.

Using the Anova App, I connect my APC Pro via WiFi and I would get prompted to update the cooker. The screen will flash 0.0 3220 a few times, then I am prompted to touch the temperature button and hold for 5 seconds to display the access code to connect my cooker. However, no matter how long I hold that button nothing is displayed.

Sounds like the same thing that happened to me about 1h ago, can’t do anything with the unit now. I have contacted support

I have the same issue. Just opened a brand new Pro and tried to connect the app via WiFi. The WiFi light on the unit comes on and the app prompts for an update. The screen changes a few times over the next few minutes and then goes off, comes back on and beeps indicating the update finished. Then the app prompts to press the temp button for 3 seconds and enter the code into the app. No code ever appears. The first time I attempted it I also received the 3220 as mentioned previously. I’ve tried everything on the Anova support pages to no avail. It’s suggested to hold down the wifi icon on the pro for 5 seconds to reset the Wifi, however as with the temperature button nothing ever happens. I’ve tried this process over 10 times. Unplugged the unit, deleted the app, rebooted the router etc.

You must hold target temp. button