New APC cannot connect to iPhone

I just purchased the Anova Precision Cooker and cannot connect it to my iPhone. I keep getting the ‘Something isn’t right’ message. I have tried unplugging the APC and deleting and reinstalling the Anova app.

Phone is an iPhone 12 Pro Max with iOS 14.2.1 with the current version of the Anova Culinary app.

Wifi is a 2.4GHz only network and the iPhone is connected to the same network.

Has anyone else been able to connect an APC with iOS 14?

Can I use Bluetooth with this device instead?

2 Likes

I’m actually running the iOS 14.3 beta and having no issues with the app. (not sure what version of iOS 14 it was I installed it on) :slight_smile: Yes, the initial pairing with your APC is over bluetooth - so you need to have bluetooth enabled on your iPhone so it can find the APC (of course, the APC also needs to be plugged in - it can’t find it if it isn’t powered on).
There are also bluetooth only versions of the APC out there, so hopefully the app doesn’t let people that purchased those needlessly try to connect with wifi. (that would certainly be frustrating) :slight_smile:

The current version of the app that I have is 3.2.11

There’s several wifi troubleshooting references here:

Thanks for the response.

It’s good to know that it works with iOS 14. Unfortunately, it means the problem is with my network, which is a little complicated.

My question about Bluetooth was to know if the app can use Bluetooth only, in the event my Wi-Fi cannot be ‘fixed’.

Hi. The APC is wifi only. Please email support@anovaculinary.com and we an assist you with pairing to your wifi.

Following…
Same problem, same iPhone…

After some help from tech support, it was determined that I had a bad unit. So, I replaced it with a new one at the store.

Unfortunately, it is doing the same thing.

I think there must be some sort of software issue with the app or the phone’s OS. Possibly, with my network (Ubiquiti). Hopefully it will get sorted eventually.

The unit functions normally so I can still cook with it. It is just an annoyance for me.

I updated my Anova App on my Android this morning and WiFi no longer works. I would not have updated if I knew the update would break my connection. Yesterday evening, it worked fine on my phone before updating.

Hi, i have same problem, tried every recomended suport couple times and still nothing

I had the same problem and I managed to fix it.
I noticed that the problem came with new app update so returning to the old version will solve the problem.

If you have an android phone just download the previous version of the app from any apk store, you can try apkpure I downloaded the older version from there and it worked.
I am sorry I don’t own an iPhone so I don’t know how can you get an older version of the app

You can’t.

But it’s good to know that it is a problem with the app. That won’t take long to get fixed.

Same issues here. I tried everything and also contacted my Internet provider, logging into the WIFI modem even learned us that the APC was visible in the list however the app says “Something isn’t right”

The customer care kept on giving me all kinds of troubleshoot options but these were all not succesful. I now filled in the replacement form but I still did not receive any follow up.

Must be a software thing and not hardware problem but there is a total lack of information about this matter.

I am having the same issue with my iPhone 12 pro max.

It shows in my iPhone settings that it is connected to bluetooth but after waiting for the update it disconnects from bluetooth and I can’t get the 4 digit code to show.

I just tried the new Anova app (iOS, v. 3.2.13, released today) and it did not help.

Has anyone tried the new app and been successful?

Do not use the new app version I had the same problem with my android phone installed the 3.2.11 and it worked on the 1st try with the new ANOVA precision cooker the new version is broken don`t use it till they fix it.

I have tried all the recommended fixes without any success. I manage to enter the code, connect it to a network and I can confirm on the router and via ping that it is connected on the network. But no success in getting it on the app (iOS 14, latest app version). Tried both iphone and ipad. Disabled all other networks than 2.4 GHz, tried different security models. But the problem isn’t to get the anova on the network itself it seems. Wish there would be a way just to enter the IP of the device in the app…

Success!

A second update (v3.2.14) appeared today and I was able to connect on the first try. It looks like they figured out what the problem was.

Happy cooking everyone!

hello, my apc works after the last update but I had to wait 12 hours to have my ribs cooked :sweat_smile:

I can confirm that pairing now works after the last app update!

Heh…I should have read to the end of the thread before resetting my device. :slight_smile: (I thought everyone was still broken) :slight_smile:

I too was able to connect successfully (running the iOS 14.3 latest release candidate (beta software) )

I do see that Anova has changed the setup, that you’re now prompted to enter your network name (SSID) and network password.

The GOOD thing is that this now seems to have rectified the issue that they had previously - when they were grabbing the information from iOS and had issues connecting to the network if you weren’t connected over your 2.4GHz radio. My iPhone is connected to the 5GHz network and there were no issues completing the wifi setup. (I stopped that during setup to confirm that my connection over bluetooth was working fine first).

App version 3.2.14
Model Number: A3
Connection Type: Wifi
Firmware Version: 4.6.7

How the Wifi setup goes after you’ve completed the bluetooth connection:

You manually enter SSID and network password

Then there was an iOS security prompt “Anova would like to add a device to your network” - clicked ok

My APC then did the 3-beeps (like the notification you get for your water coming to temp - and the app says Connected Your Anova is connected and ready to use!

Clicked Done