Pro update / connection failed

Just got the Pro, followed the connection flow. It has connected to my router, but the connection flow requires software update, and device has frozen showing:

wifi on
0.0 c
322.0 c
[blank]

This was after a few moments where the top display cycled numbers briefly like it was doing something. All buttons are unresponsive. I can ping it successfully from my PC so its on my network, but the app won’t connect. It now asks for a code, which I don’t think the Pro is supposed to (it didnt the first time), which I cant get if it were available because the buttons are dead anyway.

Any ideas? I have already turned everything on and off and reinstalled apps and restarted mobiles and tried an apple instead of my pixel.

I also tried CS chat, but its hours between replies. I can’t find a UK phone number.

db, will your new Pro operate in manual mode after a reboot?

You might want to start there while waiting to sort out remote control.

Thanks for the suggestion, it did not. CS eventually said its probably broken, I’ll return.

How disappointing, - better luck next time.

Let us know if you need any support with your first few cooks.

db, I had a exact same issue, how long did it take before they reply you? I requested for replacement but haven’t heard anything from them after one week

It took me most of the day to get through the web chat - which is probably better done via email. But as soon as they told me to do the return, and I completed the form, everything went quickly. I have a new device now and it connected as it was supposed to.

I got the automated response to the return form, then another automated email that asks if i tried the help steps, so I quickly replied to that with more details, and they confirmed shipping a new one 2 days later.