Beeping Keeps Going Off ?

For some reason the timing or temperature Beep Keeps going off.
I’m cooking a Pork Shoulder for 24-48 hrs… and the temp is staying around the correct temp (165) but it varies up or down a few degrees, which is no problem. Except when it rounds back to the correct 165, the beeper goes off… Over and Over again…

Is there a way to ‘Defeat’ this alarm Temporarily?

hopefully so.

thank you.
peter rubenstein

Hey @peterrubenstein! - there can be a few reasons why your cooker might be beeping, for example, your water level is too low. There’s a support article that explains the beeps. But, if it neither of those reasons fit, there can be an issue with your cooker - will be able to fix that for you!

Thank you for getting back to me so rapidly…
I was a tad anxious for an even quicker response, so i called your Support Help Phone Number and Carlo talked me through a simple fix. He had me press the triangle light starter button twice and that worked. (i’d had to turn the Cooker off to do a quick drain and re-bagging and that must have ‘confused the heating element’ or something…) Either way, it hasn’t beeped since. So thank you Carlo and Thank you Alyssa.

I’ve had the Tool for a few weeks and have really enjoyed experimenting with it…

1 Like

Hey Peter! Glad Carlo helped you with the beeping noise! :slight_smile: If you have any other questions or need any help - don’t hesitate to ask! @peterrubenstein

Hi I’m having the exact same problem. Tried pressing the start/stop button twice and it’s still happening.

I’d set the temperature to 57 degree celcius and it will heat it up to about 60 and slowly fall back to 57 where it will beep and kept falling slowly till 56.7 where it will start falling faster to about 55.6, which prompted the unit to heat it back up again to 60. And it just repeats itself and beeps when it reaches 57.

@Ryantaybl Have you tried to give your Anova Precision Cooker a short rest for 24 hours? Sometimes this can remedy the issue. Either way, I’d shoot a message to so they can dig into the issue and fix it!

This may sound obvious, but if you haven’t tried it yet, give this a shot…
Try unplugging the unit, waiting a short while (not quite the 24 hours Alyssa suggested,) a couple of minutes, maybe… Then replug and reset the temp and/or time - Also, one thing i over looked was the water level - so make sure you’ve the Anova floating in sufficient liquid.
You can always give it the 24 hour rest if this simple one doesn’t work…
good luck.

Yup i use it like twice a week so it had a longer than 24 hours rest sometimes, tried waiting a short while too and my water level should be sufficient (3/4 from min-max) like what Peter suggests; no luck still.

So it looks like the long rest wont work for you! Blahhhhhh. Have you messaged customer support yet? @Ryantaybl

Hi Alyssa nope not yet should I?

Yes, please! They can troubleshoot and get to the nitty gritty to what’s going on with your cooker!

Ok so I realise this is old but I haven’t seen a solution. I figured out that for me the housing outside the coil needs to be placed, twisted and seated correctly. If it’s been removed to clean or whatever then the chances are it has not been put back correctly. This will result in wildly fluctuating temperatures and the accompanying beeps whenever it passes through the desired temp. Rule of thumb is that you should see the water affected by the pump. If the water is totally still then the housing is not on correctly. Hope this helps others!