Beeping, unstable temperature

Received my 220v precision cooker on tuesday, and I’m struggling to get it to work properly. When I set it to e.g. 65C, it keeps going up and down between approx. 67 and 63, and it beeps every time it reaches 65 again. I’ve tried to cover my pot as good as possible which has helped the situation somewhat, but it’s still very unstable. Any tips?

I’ve noticed mine is doing that today, set at 190F and it beeped, then starts swinging up to 200 and down to 180 for the last half hour, and beeps every time it thinks it’s hit 190F again, but my Thermapen was registering about 10F lower. Unfortunately no tips for you, but I’m going to probably put in a support ticket to see if this is a known issue with some. Previously my only issue was the calibration being off and I thought I’d just wait for the iPhone app to sort that, now it seems like there may be more wrong with it unfortunately.

It seems to me that Anova becomes unstable above 190°F (there might be some physical reasons for such instability close to boiling point - though more likely there is some bug in algorithms). Fortunately, I don’t know a single Sous Vide recipe which calls for temperature higher than 183°F (that’s standard for veggies).

The are some use cases for temperatures around 85°C/185°C.

One is Dulce de leche, an other are caramelised onions.

While doing a test drive for Dulce de leche with my Precision Cooker I observed a similar faulty behaviour.

I’ve made a short clip of that:

Video: Precision Cooker Temperature Malfunction

Had to switch back to my Anova One to finish.

That issue is filed at Anova and I got a similar answer, that this will be sorted out when the app will arrive and some kind of recalibration will be possible.

@vtemkin‌ in the meantime I’m using your app - thx a lot btw - but I doubt that issue can be solved by just adding some calibration offset.

My assumption is that the water steam - which in my case is evaporating directly along the Precision Cooker due to using a cut-out box cover - is causing some heat problems in the controller.

Thanks everyone for the info, yes I had it set too high. I thought my veggie recipe was for 190 but I read it wrong. At 183 it’s working fine.

I had a similar problem, though at a much lower temperature (48c). Though I think the beeping might only be when it passes the set temp (rather than a direct symptom of the problem).

I have similar issues: