Bluetooth control not working. Connection seems fine

After having owned my Precision Cooker for over 9 months now, I finally tried the official app to control it via Bluetooth, but something does not seem to be working correctly.

The app appears to be able to find and connect to the device just fine, but I am unable to to control the Precision Cooker (start/stop, set temperature, set time) or get the actual temperature from the hardware. The bluetooth light on the Precision Cooker even lights up blue when the connection is established.

The program acts as if everything is completely in order, without the device ever acknowleding a single command I try to issue. I can even set the temperature or the timer in the app, but the changes are never reflected on the actual hardware.

Does anyone have an idea how I can get my unit to communicate correctly over bluetooth?
It's not a deal breaker per se since the device is working just fine without bluetooth control, but it would be really nice if this last bit would also be working as intended ;)

Some info about my devices, if this is important:
Unit: Anova Precision Cooker 220V (got as a Kickstarter reward)
Smartphone: Nexus 5 (running the latest Android 5.1.1 and the latest version of the official Anova app)

I also made an album to show the problem from my point of view:

Thanks for any help you can provide!
Best regards.

My problem is similar except I can’t connect at all. The Anova is fine (or was up to and including yesterday) 

I have been using the Anova Remote paid app up until now - I trialled the official app when it came out but went back to the AR app. Unfortunately it is now giving a Force Close when I try to use it so I figured to use the official app while AR fix the problem.

The device appears to be working fine - I just set it by hand for my hangar steak, but the app simply can’t find it. As for eggsbaconandspam, the BT light goes blue but there’s no connection.

I tried the procedure at as suggested in another thread. It is basically just turn on BT then start the app and connect.

Didn’t work.

I then tried connecting to the Anova directly in the BT screen (it shows up there) but it wants a passkey - tried the usuals (0000, 1234, 12345, 00000) and none worked.

I then went back to the app and tried a connect and it found the Anova.

@eggsbaconandspam, maybe try that?

@eggsbaconandspam Hmm - We had a small batch of KS devices that were listing the BT chip as HMSoft and causing a positive connection but no communication. With your device being from KS, its quite possible that its the culprit.

You can reach out to our support team at and we’ll gladly help you out :slight_smile:
@Journyman this goes for you too ! 

I have a BT/wi-fi combo unit that I just received a couple of weeks ago. Aside from being unable to connect to wi-fi, I have BT connectivity, but I can’t see that it does anything. It’s not noted in the current app and I so there doesn’t seem to be any point in having BT. Any advice?

Hello out there can someone help with an experiment for me, 

i am convinced that bluetooth does not work on my device.

if i have phone wifi on, bluetooth off / router on / A.P.C wifi on. works all good.

if i have phone wifi off, bluetooth on / router on / A.P.C wifi on. works all good

if i have phone wifi off, bluetooth on / router OFF / A.P.C wifi ( there is no switch to make bluetooth ) NOT GOOD DOES NOT WORK.

if phone wifi off, bluetooth off / router on /  A.P.C wifi on. works all good.

my conclusion is that bluetooth does not work without A.P.C connection to wifi there fore if you was to be outside cooking with power but no wifi you would not be able to use bluetooth commands

please help with this dilemer thanks


and yes i have done resets, reboots, plug ins, plug outs and trouble shooting that i can think of.


and i have done resets, reboots, plug ins, plug outs and anyother troubleshooting that can 

Not good enough! Date now 26/05/2019 6 months more or less since this issue was raised.

I too have paid for the option of both Bluetooth and wifi.

First I set it up it detected my 5g you would have thought it would have been designed to know the difference, not even an option to chose network just assigned the network, though at the same time stated it needed 2.4g so why not locate the 2.4 No I had to go into router switch off 5g uninstall app and start again. what if I did not know how to do that?

fine, I thought at least it is sorted.

I was wrong it almost got to temperature then lost connection, I checked router it was still connected. checked to devise it states it is not. Uninstalled again, Unassigned even deactivated wifi on phone. NO option to use the Bluetooth. I thought it was supposed to detect Bluetooth first, it does not even have a Bluetooth icon just a stupid flashing wifi one. this toy is not cheap and when we pay for both Bluetooth and wifi options they should both work.

It is stated the iPhone has both wifi app and Bluetooth app yet android only has wifi, what kind of planning is that.

It is stated that the culinary app is the Bluetooth app wrong again when I downloaded the only app showing for as it starts asking for wifi and when I try and bypass that with my phone practically sitting in the water with it it still cannot detect Bluetooth.

there is a touch screen on top for wifi why not one for Bluetooth, are you perhaps misleading customers and that is why Bluetooth app is no longer available, just a thought.

The frustrating thing is my friend who bought the Bluetooth version (He uses Android) and was the one who convinced me to buy this piece of crap.

Is this going to be fixed before my warranty runs out, all day I have been messing around doing this, I charge £600 day rate for my photography work that is a day wasted.