Can't Add Recipes In App

When I try to add a recipe in the app on my iPhone X I click the “Save” button and nothing happens.

Same with my iPhone 5s

Hey guys. Which version of the app do you have currently downloaded? Were you able to save a recipe before and now you cannot?

Using the latest version 2.8.11. I tried naming the recipe while cooking but that never saved before. I’ve never been able to save a recipe.

@tonytroz thank you very much. I’ll be checking in with the team about the bug.

I emailed Anova support and they suggested signing out of the app, terminating the app completely, and then logging back in. That solved the issue!

1 Like

it was working smooth on my iPad Pro when it was running on ios 10 however as I have updated to ios 11.3 whenever now I am opening the app it only loads a blank screen on the start up and crashes after a while automatically. How do I fix it?
with regards vidmate

Same thing happened to me. But I found this message trail and logged out and then back in to my Anova and it worked!
Problem now is that I have 9 pages of one recipe (Porterhouse Steak) and can’t seem to get rid of them.

Sent email to Anova Support and will let you know what they can come up with. Is this a bug or a feature?


Nine pages in one recipe? I do know there are a few steps for the porterhouse steak recipe, but the flow should make sense. Thank you for reaching out to support - we’ll definitely look into this for you.

Alyssa -

The problem is 9 pages of the SAME recipe. I’ve been working with your support group and as of now, we still have not been able to fix the problem. I have had my account deleted several times today (at my request) to see if we could start from scratch. Nothing seems to help (even registering from the App.) Seems like the my data is stuck in the system with no way of being deleted so I can start afresh. I think this has something to with the latest update.

The support team has been very helpful and patient. My hats off to them for trying.

:frowning: mgolini