Can't Connect Device

I got my new Anova Precision Cooker but can’t connect it with my phone/Wifi,
I only have one wifi network (didn’t say it is 2.4GHz or 5 GHz)
A code is generated by pressing the target temperature button and i entered the code on the app but it keep asking me to “Enter the code displayed on your Anova”. I have entered almost 10 times but it is still not connected.
Does anyone have the same problem?

Probably best if you contact Support. We’re only users here.

I had the same problem - endless requests to type in the code after my phone asked me to join the custom Wi-Fi network it created.

Somehow I got it to work, and I don’t remember how. It was not intuitive at all.

If clarification can be posted here that would be great, for others or if we need to reconnect the device.

I would be interested if ANYONE has got the new app to work. I use iphone 7 and the old app used to work great - although a bit clunky. The new app has never worked for me! No problems connecting to any number of Bluetooth devices from other manufacturers. Draw your own conclusions. Its a great cooker used manually, but don’t buy one if you expect the App to work.

I am able to get it connected… but it is hit or miss. I think that is due to the fact that I might be on a different network (5 GHz vs. 2.4 GHz) than what the sous vide is (2.4 GHz ~ I believe). In our house, both networks are the same name, so I don’t know for sure which one I am on at a given time, other than I am connected.

Thankfully I work from home, so its not as big of a concern, but I can see this being an issue for others. And as one user pointed out, what’s the point of having a wifi machine if you can’t take true advantage of the wifi capabilities.

I updated my iPhone to IOS13 and it won’t connect to my Anova… it works fine with my wife’s iPhone since She’s still using IOS12… I sent Anova an email so hopefully they will have an update soon…

My precision cooker won’t connect to Wi-Fi either. I am using the 2.4 GHz connection, but the app tries connect forever without success.

I just bought the Precision Pro and you dont need to look for a code. You just connect through the app.

Also I was having trouble connecting to the wifi - read the troubleshooting guide and found out it is because I had a space in my wifi name. Changed the name and all is good!

It is absolutely mind bending that, after years of complaints about this, the new device has the same issue. There is no reason for not allowing spaces in wifi network names, other than programmer incompetence.


I couldn’t connect my pro at all, called support and was told that iOS13 would not connect till the Anova app was updated. Looked this morning and saw the app had been updated, everything is working great, I hope it stays this way for awhile.

I have a Pro and have the same problem.

Initially it connected fine (perhaps over BT bec I didn’t have to hold down the button for 5 seconds). Even set it up on my WiFi just fine. Then the app prompted me for a software update. Afterwards, it seems to need reconnection.

Now, I am stuck in the same cycle as the original poster. I opened a ticket with support to see if any insights. I reinstalled the app, so I am assuming it is now on the latest version.

I have one of the new Precision Cookers after my old one up and died after a solid few years of use. Out of the box it would not connect to my Pixel 4. It connected to my old Pixel and my iPhone (I have a lot of phones). The WIFI netowrk would not connect because the password had characters other than A-Z 0-1. So I set up a separate VLAN outside my main netowrk and it connected fine on my iPhone (iOS 13.2). Still not even getting the WIFI list on my Pixel 4.

Fast forward a week. iPhone on iOS13.2.2, saw the Precision Cooker had a firmware update. So I updated it. BAD mistake.

Now nothing will connect to the Precision cooker. iPhone stopped connecting so I tried to set up the connection again.
The iPhone connects but the WIFI list is empty, so I no longer can connect to anything. I live in a condo surrounded by literally dozens of WIFI signals of all stripes, and I get an empty list. Going to try with an ancient iPhone on iOS12 to see if that is hte issue. Pixel 4, still spins and spins and no WIFI list shows up, sad.

Bought it at Willian-Sonoma, so I probably can return it and get something else that has all the features that actually work. I’ll give it a week to see if it’s Apple’s fault, iOS 13 is a dumpster fire afterall, but not even getting a wifi list on my Pixel 4 is more than annoying.

These Agile development methods that treat the customer as a testing pool is getting very tired.

Tried on iPhone 6s (iOS12) and connects, but WIFI list is empty. So the firmware update fried the WIFI setup. So sad.

Eventually I discovered a solution for my failure to reconnect after firmware update issue. I found that I had to both uninstall the Anova app on iOS (as documented) and reboot the phone. Then I reinstalled the app and was able to connect.

I stumbled upon this bec I noticed that I can connect just fine with my iPad (which never had a connection) after the firmware update. So I guessed that there must be some cruft on my iPhone. Uninstalling (to delete settings) and rebooting seemed to restore the iPhone to a clean state for connection.

Hi All,

I had the same problem. Couldn’t set the connection with my iPhone. I tried with my iPad … And that worked fine at 1st try.
There was a firmware update which I installed. And I setup the connection again afterwards.
Again same situation… Worked well via iPad, but no way to get my iPhone 7+ connected.

Conclusion… I get a connection with my iPad, not with iPhone

(iPhone 8, iOs 13.3, Precision cooker (new))
Can confirm the whole connection issues - was able to connect using an iPad, and an Android device, same wifi, same house. (Therefore the issue was not the wifi but the individual iPhone)
Issue we had was upon entering the code, got dialogue box asking to ‘join Anovaxxxx wifi?’ (yes), then enter code, then…‘please enter the code’, just a loop of entering and being asked to enter again. Rebooting the Cooker made no difference. Turning off the phones Bluetooth and WiFi multiple times made no difference.

FINAL SUCCESSFUL SOLUTION to this problem: upgrade iOs, delete Anova app entirely, REBOOT PHONE (turn fully off, and back on), and then reinstall Anova app fresh. After 2 hours, about 50 codes, and a lot of research, this was what worked.

Thanks Hugh. Worked almost immediately after deleting the Anova App, rebooting iPhone and reinstalling the app.

Truly stunning software, innit?

Ditto- thanks!

Hi Guys,

I have my anova Wifi for years. But since my last cook the wifi isnt working anymore. I reinstalled the app on my IPhone and tried a Android device. I completly reseted the Anova without success. I tried to lay the Anova directly next to the router. Also no success.

Any other ideas?

Thanks you for your help