Can't get 4 digit code for wifi connection

When trying to connect my Anova Precision Cooker Pro to my wifi and the Anova culinary app. I have been unsuccessful.

I have tried everything - in the app i follow the on screen instructions and get to the point where i need the 4 digit code from the device and need to enter it on my phone. When it prompts me to press and hold the target temp button no code shows up…have been stuck on this forever and tried all the troubleshooting in the world.

Any help would be appreciated - thank you!

I had the same issue with my first Pro. Tech support recommended performing a restart by holding the temperature, target temperature and timer buttons down for several seconds. They advised the Pro would restart. In my case it didn’t, and they directed me to submit a replacement form. Hope yours works better!

Hello same thing for me, nothing more happens. I have tried everything. What is this material, I’ve seen on a lot of forums people have a lot of problems …