Current temp stuck at 32 degrees

Yes, it works great. No problems so far.

I don’t think you need to disassemble it quite as far as I did, It was mostly part of the investigation.
There is one part that you must remove and it’s not that easy - the small board in the second picture (the one that has “CR1120” written on it). The chip is under it.
This board is soldered to the bottom board via 6 pins. You can either try to heat them with a soldering iron and a lot of solder (bridge them with solder so that you can heat multiple pins at once) while you pry on the sides alternately to slowly move it up on the pins until it’s out, or wick all the solder until there’s no solder connecting the pins to the pads or at least a small amount that can easily be broken loose.

As for the chip replacement, the hardest part in the process is removing the bad chip from the board. The best method is a heat gun and a lot of flux. If you don’t have a heat gun, you can cut the legs from the chip with flush cutters (it’s going to the garbage so it doesn’t matter if you destroy it). Then desolder the legs one by one. Just make sure not to damage the board when cutting.

After that, clean the solder pads on the board, remove the solder and clean with alcohol. I suggest using a solder wick, but a multi-strand wire can be used in the same way.

Place the new chip in the same orientation as the old one and press lightly with a pair of tweezers to keep it in place. Applying some flux before you place the chip may help stick it down.
Solder one pin on either side of the chip, that will help prevent it from moving when you solder the rest.
If you have some soldering experience, try to apply flux on all the pins, load the soldering iron with solder and sweep it across the pins. The flux should prevent the solder from bridging the pins.
If you don’t feel confident with doing that, just solder pin by pin with a fine tip soldering iron.

Clean the board with alcohol (best practice is an ultrasonic cleaner, but I’m guessing most wouldn’t have access to one), reassemble and test. (you can test it while it’s disassembled, but that’s risky for many reasons, do it at your own risk)

I wouldn’t call it easy nor simple if you don’t have the tools and/or skill, but it’s definitely doable for someone with good hands and simple soldering tools.
Best of luck!

Hi the issue with my precision cooker is that it is circulating but the temperature is not rising at all . I only used it once . It is stuck at 94 F .
Can you advise what could the issue be

If the set temp isn’t 94F, then you should contact Anova Support. (see the support link at the top of the page) - sounds like you may have a defective unit - they’ll help you out with some troubleshooting and fix you up with a warranty replacement, should your unit not be functioning properly.

(the community is fellow Anova customers, sharing information).

Made an account just to say what a fantastic writeup. Thanks so much for posting it here. Looking forward to gutting my unit.

My anova cooker pro cant gain temperature at all ?! Last time used before 3 days and i bought it from augusta very weird…

You should contact support (see the menu option at the top of the page). These forums are Anova customers helping each other. Support should be able to determine what the problem is with your unit and recommend a solution.

I read all posts here and I realized that I am not alone.

Few years ago I acquired two identical Anova machines (127 V used in US and another one under 220V to be used in another country).
After few uses (less than 15 times) one of the devices had the same problem described by several users (here and at other places I found on Internet): It stays reading 32o F (0o C) no matter what. Is quite easy to find out about the defective status as 32oF is NOT a kitchen’s temperature to start with.

As a consequence of the “frozen” temperature the device does not control anything and keeps heating up till boils the water.

One of the owners posted at this group (Harari) a very well investigation of the issue and he was able to find the defective component and successfully repaired it.

I followed his path and found the same problem. Great! But I realized a much more serious reason for so many people having the same or other electronic problems.

Yes, despite my device was used very few times during the disassembly I realized the humidity from the bath is getting through the head (where all electronics are sitting) and this is THE REASON for the failure.

I am the only person that uses the device at home (both devices) and so no other person cleans them. The electronic heads were never ever immersed or got any splash of tap water as I always took good care of it. No matter the care I gave to the devices the vapors are getting into the head provoking corrosion at certain portions of the boards as making short-circuits.
90% of the meats prepared at both Anova’s devices stayed there for more than 48hours (at least once meat stayed 72h).

Both devices are out of warranty and Anova does NOT offer technical assistance (even if you want to pay for it). It means that after the warranty time you have to repair by yourself (or using someone with necessary tools and components), or to buy a new sous vide machine.

To know that Anova provides no technical assistance was a very big deception.

First photo below shows the humidity everywhere and the second photo is the same but magnified to better show the component mentioned at the post. Anyone will see what the humidity was doing at all !

My conclusion is that Anova should offer a replacement for any device with such problems. This is a clear reason for a recall.

Any technical institute will need a very small effort to prove the water vapors from the bath vessel are going through the head of the device. Once the vapor touches the very top of the device it changes its status (from vapor to water) and those drops of water stays over the components slowly destroying them until full failure.

I even amplified the image of several other portions of the boards (all) and found water residues (dried or not).

WOW, thanks a lot! I have a device that is stuck at -26C . Do you think this solution could help as well?

Hi I received an Anova Precision Cooker with the same problem from a client, stucked at 0°C or 32°F, but the model wasn’t the same as Hahari had an the TM7707 doesn’t not exists on the board. So I follow the circuit and find another component that convert analogical signals to digital. It’s CS1237-SO. After changing this component the problem was solved. It wasn’t easy to fix, because you must have some skills with a heat gun. As I live in Brazil ,there wasn’t help support here neither replacement components. So I bought from China and waited for 30 days… If you live in Brazil and are facing the same problem, send me an email to, maybe I could help you.

1 Like

I have had this failure as well. I replaced the CS1237-SO, twice! It works for as long as it’s left on but if the unit cools down (i.e. is left off overnight) on the next startup it seems to fry the CS1237-SO again, which suggests a power supply issue in the unit. I have not had time to try to diagnose it further. It appears there is a DC-DC switch mode on the upper boards (but no electrolytic caps visible there) and an AC-DC down in the main unit (but electrolytic cap); I’m not sure which will be the culprit, although the AC-DC is much harder to access as it appears to be on a daughter board that is in the middle of all the wiring and water-empty cutoff board. Has anyone else had a similar experience and determined the root cause? Thanks

P.S. I’ve bought an InkBird ISV-200W as a backup now and it’s so quiet compared tot he Anova… I’m amazed. I’m still keen to repair the Anova as a backup.

So is replacing the A/D chip a definitive fix?
Are replacement thermistor rods available? Has anyone figured out what thermistors are used?

Hi all… I have a similar problem and have purchased the TM7707 chip but unable to locate it. I have disassembled the bottom half but was reluctant to take apart the top section (LCD display unit) without confirming the chip is located there. Is someone able to confirm before I pull apart the top?

I was unable to view all the images @harari had posted as some of them don’t appear to be available any more.

If anyone has additional details or images, it would be appreciated.


Your settings, all displaying fine & opening in new tabs for me (which I had to do to each as you neglected to mention which ones you were having trouble with)

I can both see & open all.

I got an Anova sous vide for this Christmas and it has the exact same problem. How is it that Anova has not been able to fix this issue in over 7 years?

I will never buy another Anova product.

I bought the Monprice Sous Vide and it is a great product (compared to Anova’s crappy product). It worked right out the box without any issues.

Mate, read the whole thread, do some research, you may well be able to reset your unit (if you do the tiniest bit of research) …why have you not taken advantage of the two year warranty? (instead you seem to come on here as a first post diss the brand (so do I at times) & place a reference to another brand, are you real or is this spambot type product placement, I really cannot tell at this point.

Did you even try contacting Anova for a product that is not even 2 months old !?