Current temp stuck at 32 degrees

Just got the precision cooker and excited to use it. Plugged it in and downloaded the app and everything seemed fine…but after i set the desired temp and pressed play and could her the motor start running. the problem? the current temp is stuck at 32 degrees for like an hour now and hasn’t moved at all. It feels like the water is getting warmer but no change. anyone else with this issue?

A day later - hopefully things turned out.
You didn’t say what the target temperature was?
How big is the vessel that you’re cooking in? (you’re not trying to use your bath tub, right?) :wink:

Provided you’re using a vessel within the range supported by the PC (max 22 litres - or close to it - unless the container is insulated…then it depends) and provided the water depth is between the min and max levels marked on the side of the circulator’s stainless lower body, you should be seeing your bath warm to the desired temperature.

Also, if the vessel you’re using is uncovered, be aware of the impact of steam on your precision cooker - make sure the vents at the top of the PC are facing the outside of the vessel and not being subjected to steam.

  • and you’ve power cycled the PC
  • and you’ve tried setting the target temp manually, using the dial, rather than using the software.

If you’ve done everything right and it won’t heat beyond 32 degrees, then I’d say you have a defective unit and need to either return it to the retailer you purchased it from or contact Anova for a warranty replacement.
support@anovaculinary.com

1 Like

I have the same problem 800 watt model purchased Nov 2016. This is my 5th time using the Anova and temp stays at 32 degrees. The prior cooks the temperature rose as the water got hotter, not anymore. I set the water temp to 130 to cook steaks and used a Thermapen to check it was well over 200. Thankfully I got in touch with Customer Service and they sent me a Fedex postage paid label, this unit is going back. Maybe I got a defective unit. All of my cooks so far have been in an open stock pot, not covered.

@toddh808 sorry about the defective unit. It does help to have cooks covered to avoid any damage caused by steam - but I am happy that customer support took care of you!

Same problem. Last year it would be set at 135 and fluctuate between 190, 299 and 350. I tried it again today after a year and now it is stuck on 32 degrees. It was a gift so I don’t have a receipt. I’ve used it total of five times and three of them didn’t work. This is the biggest, most expensive piece of crap I’ve ever used. Not going to use Anova ever again.

Did you get in touch with support at all? Or did you just set it aside and expect it to self repair or perhaps for the magic pixie folk to fix it?

I’ve had the same problem for the last few times I’ve used my cooker. It seems that setting it up, trying and failing, followed by a long period of being unplugged ‘fixes’ the issue.

My experience yesterday: I use a small cooler as a cooking vessel. I clamp the unit inside, fill with water, and then plug in the Anova. I can connect the unit to my phone via Bluetooth and see the two temps. The current temp shows 32F and the Set temp shows 60F, same on the phone as on the unit. I can set the temp using the phone but the Start Cooking button is not active. I can push the manual start button on the unit and the circulator begins.The water gets warm over time but the current temp reading remains at 32.

I wanted to have pork chops ready to finish when I got home from church yesterday but was frustrated by the unit not working as described above. I unplugged it, disconnected my phone, and left it all set up on the counter. Later that afternoon, thinking I would try for dinner pork chops, I plugged the unit in and miraculously the current temp showed 92 degrees. I reconnected my phone, was able to set a target temp and time and started cooking. It worked.

I’ve had this unit a couple years (got it as a gift) and I’m not sure if it ever worked correctly right out of the box. I’ve always had to fiddle with it to either get it connected to my phone or get it to work at all. Allegedly you can set the temp and time manually on the unit using the thumb wheel but I’ve never gotten that to work either. Buggy and wonky but I haven’t ruined any food yet, just been frustrated by the process.

I have the same problem. Apparently there is no cure? Depressing.

Fortunately there are now some good alternative sous vide devices.

I had the same problem as you and many more on the internet and I didn’t find any help online nor with the support, so I fixed it myself and figured I’d share what I found so it might help someone.

The problem was the ADC (analog to digital converter). It’s what’s taking the temperature sensor’s readings and converts it to something the processor can understand. I checked multiple things (if the process interests someone - tell me and I’ll elaborate) and everything looked fine except for the signal not reaching the processor.
I bought the same component online (TM7707), replaced the original and it started working again. accurate temps and everything.
From what I read about people’s experience and what I saw inside the device, it’s very likely the same problem with all stuck 32F / 0C devices.

NOTE: you’ll need some soldering skills and tools for this. You might get away with just a soldering iron, but a hot air station makes it much easier.

here is a picture of the board and the component:

NOTE2: I saw some people still using the device as a heater without temperature regulation - I was really surprised there’s no thermal runaway protection in this thing, that’s a real fire hazard. please don’t do this.

Hope this helps someone.

6 Likes

Hi @harari

The process does interest me! If you don’t mind taking the time to elaborate I’d love to hear the process you went through in as much detail as you can provide! Thanks

1 Like

I’ll try to go into as much detail as I can and explain what I did and why. If there are any questions, don’t hesitate :slight_smile:

First, I tried to guess what’s wrong from what I can see without opening the device.
I know the controller works since it turns on, has a working display and the buttons also work.
I know the motor and heater are working, this means that the power supply section is also fine.
The biggest clue was the temperature itself. while 32F seems arbitrary, 0C can’t be a coincidence. I suspected that it wasn’t just stuck at some temperature, but displaying the default value when not getting a valid reading.
This means either the thermistor itself is faulty or the reading is not getting where it needs to go.

Then I opened it to have a closer look and figure out what everything does.
There are 3 metal tubes with wires coming out of them, these are the temperature sensors and the water level sensor, but which is which?
One tube has 3 wires coming out of it and is not touching anything. Two of the wires are green, these are the wires for the thermistor (this makes sense since thermistors don’t care about polarization, so they usually have the same color wires). The extra wire is connected to the tube itself and is part of the water level sensor.
Another, shorter, tube has only one wire coming out of it and the tube itself is also not touching anything. The wire is connected to the tube itself - This is the other part of the water level sensor. When the water reaches the shorter tube, it shorts the two tube bodies together, thus indicating to the controller that the water has reached the desired level. (This means that this wouldn’t work in distilled water, good to know).
The last tube has 2 wires and is clamped to the heater. The wires are the same color (red) so I suspected that this is another thermistor, but why two?
After following the thermostor wires and the traces on the board, I saw that the red wires were connected to the same board as the green wires, but the red wires’ traces on the board stay on the board and lead to part of the power circuit. The green wires lead to a connector, from that they go to another board via a flat ribbon cable and then to some component on the second board. (There was also a small board which had the connectivity hardware that had to be removed in order to reach the components under it)
This told me that the red-wired thermistor is not read by the controller and is only used for protection if the heater gets too hot.
The green-wired thermistor is the actual water temperature sensor.

After I was confident I understood how everything comes together, I started troubleshooting.
I measured the resistance of both the thermistors and they came out about the same and a value that makes sense for a working thermistor (can’t rememeber the specific value, it’s in the KOhms range).
To make sure that the problem isn’t with the thermistor itself, I swapped the thermistors. I connected the green wires instead of the red and vice-versa and powered the device. No change, still 0C and the motor and heater still work. So both the thermistors are fine. (BTW, in order to test the heater and motor, I shorted the two tubes with a screwdriver to trick the controller to think there’s water between them)
This led me to suspect the component that the thermistor is reaching (I followed the traces as I mentioned, and checked continuity with a meter and it seems fine up to the component)
I also followed the traces from the component to the processor and they seem fine too.
I checked what this component does and google revealed it’s an ACD. AHA! that makes total sense.
I downloaded the datasheets for both the ADC and the processor and made sure the pins were connected to where they should - and they were.
I desoldered the ADC and resoldered it to the board to make sure it’s not just a cracked solder joint or a short, but it didn’t help.
I also tried cleaning all the boards with alcohol and an ultrasonic cleaner to eliminate the possibility of particles causing a short. It didn’t help also.This led me to the conclusion that most likely the ADC is dead.
I thought about probing the ADC and seeing what it outputs, but the datasheet for it was not very helpful and mostly in Chinese, so I decided to replace it since it’s very cheap.
After the component arrived (a month later), I swapped the ADC with the new one and tested again - SUCCESS!
Put everything together, tested again and started cooking.

Here are more photos of the inside:







4 Likes

Much appreciated @harari! Thank you!!!

I should mention that I haven’t experienced any problems with my own Anova cooker, but I appreciate the detailed troubleshooting and documentation of the steps you’ve taken to fix your unit. In the event I ever have a problem with my Anova this will let me start at somewhere other than the “ground floor”! :slight_smile:

Just finally received my anova 2019 edition (after a long shipping wait) and have just used for the first time.
Was working absolutely fine, target temp 131 for 2 hours. After about an 1 hour the temp said it was lowering when in fact the water started to get hotter and hotter. Then the machine would only give a reading of 32.8 degrees. A very common problem I’ve seen alot of people have. I really have very little faith in this company anymore. The customer service is shocking, but now it also seems that the product is not fit for purpose. This is not a cheap item and can not simply perform the one action it was built to do. I don’t even really want a replacement as I feel it would just be another long process when I feel that will inevitably fail. I feel I will be moving on to the joule unit when I receive a refund.

Hi harari. First things first, thanks for the detailed procedure. I’m stuck with the same issue and will try to save my device by swapping the TM7707 chip. Do you mind to share where did you manage to get the chip from? No luck with a quick web search, then from China it seems a number of variants for this Chipset is available. Thanks in advance! Kind regards.

Hi, pinheirod, sorry for the late response.

Here’s a link to the same listing from which I ordered:
https://www.aliexpress.com/item/32980011811.html?spm=a2g0s.9042311.0.0.27424c4drHknGt

Here’s a link to an eBay listing of the same chip and the same form factor:

Different variants are probably just different manufacturers making the same chip, they will all probably work if they’re the same form factor and have the same pinout.

Hope this helps.

Hey Harari! Thanks for being so detailed! Im having a problem to purchase this ADC from the ebay link, because I live in Brazil, and this seller is not shipping here. I dont understand anything about this component, so if you could send one more link so I can try to find some seller that could ship it to brazil, id be very thankfull. I have 2 anovas here with the same problem as everyone here, very frustrating.

Do you think one of these would work?

Hey, Marcelo_Mureb,
The links you provided are for completely different components, so they wouldn’t work here.
From what I see, the seller from my last eBay link does ship worldwide including Brazil, There’s an option to calculate shipping to Brazil and I tried entering a random Brazilian address and I don’t get any errors.
You should be able to order from that link.

A+

Good work, harari -

Any update? Did your fix work? My Anova just bricked at about 2 years old. I ordered that chip for 3$ US, and see how far I can get. Can you offer any advice on how the soldering goes? That is a lot of pins, and I have never done anything that small. I really appreciate your posting!

Thanks,

Darren

PS - after reviewing your pictures, which are very cool, it appears you had to completely disassemble the pc board to get to the chip, which I interpret as an Expert Hack, vs a simply DIY. Is it true you had to clear a major path to get to this chip, or were you just investigating to learn the problem?

TIA