Eero + APC WiFi = Fail

Please tell me if I’m hosed or if there is hope for a fix…

I’m on day two with my APC Wifi model, and have not been able to get it to connect to my Eero wifi.

I assume it’s because the app says it want’s to use my 2.4 ghz connection. In the eero system, the eero decides if you get on the 5 or the 2.4 connection

I’ve tried using an iPhone 6, an iPhone 5, an iPad Pro 9.7 to no avail.

Very sad-happy right now… Been looking forward to getting this for weeks, now seems like I could have saved $80 getting the bluetooth model ($120 vs $200 at amazon at the time).

Is there any way that you can temporarily disable the 5GHz network? (presuming you have both bands with the same SSID, right? - that’s why you can’t differentiate them during setup?)

Your iPhone should be connected to the 2.4GHz network that you want the ANova to connect to.

If you can temporarily disable the 5GHz band, then complete the ANova setup, you can re-enable it after the fact.

Thanks for the reply.

Eero doesn’t have settings to disable either band. (at least not ‘user-available’ settings)

I tried the next best thing, to no avail…

  • I went outside with my phone and my APC Wifi plugged into an extension cord.
  • I walked away from my house until my Eero app reported that I was connected to the 2.4 Ghz network, and then walked a few steps farther.
  • I opened the Anova app on my phone and tried to pair the APC to wifi… Fail.

Yep, the 2.4GHz range carries further - good test, but the downside being that your phone has a more powerful wifi radio than the Anova PC does. :frowning:

Have you contacted Eero support yet, so see if they have a way of forcing the network into 2.4GHz mode?

Another option I thought of - if you had another WAP (wireless access point) available, you could configured it in 2.4GHz mode with the same credentials (SSID, and security settings) as your home Eero network temporarily to get your Anova PC configured (it would also require internet access) - maybe you have a friend that would be willing to reconfigure their home network for you for the experiment? :slight_smile: Once the ANova has that network saved, it should connect to the 2.4GHz network at your home.

1 Like

Is this still a fail? I just ordered a WiFI PC yesterday and have an Eero mesh Wi-Fi network. I did not see this post during the research process, thinking that Wi-Fi connectivity would be a slam dunk. If it is still an issue I’ll return the PC without opening.

Thank you
WJ

Yes, still fail. Tried again about two weeks ago (?) after an app update. No luck.

I still recommend the PC to everone i talk to, i just tell them get the bluetooth version. Turns out, we dont even use the bluetooth function.

1 Like

I’m not at 100% in my understanding of how the wifi APC connects to wifi, but it seems very likely to me that if you have difficulty pairing it to eero (haven’t actually heard of this before) you could likely set up some kind of temp wifi network on 2.4ghz only.

Use separate equipment but the same SSID and password, connect your phone to it, use the phone to pair the cooker, and switch off the temporary equipment.

The cooker will likely then connect to the eero equipment, if it hadn’t already. Definitely a pain in the butt, though you should only have to do it once.

I use Ubiquiti kit, and I had to force my cellphone onto 2.4ghz before i could successfully pair the cooker.

1 Like

Thank you @Walter_Ego and @chill for your replies. My APC arrived and since I was unable to get a definitive answer from the community manager @AlyssaWOAH on this (she went very quiet after I asked the question), I went ahead and broke open the device. Like you say, a 2.4 GHz WiFi network is the only way the APC will connect. I tried with my iPhone 6s, however I have no way to either turn off the 5 GHz radio on either my phone or my eero router/AP’s. The setup failed. My daughters iPhone however connects using 2.4 GHz, so I commandeered her phone. loaded the app, paired and got the APC to connect. I then unpaired, and repaired my iPhone. Tried several power cycles of the APC and it appears to reconnect to the WiFi network each time. It seems crazy that the WiFi configuration for the APC uses the host, BT paired device to set up WiFi connectivity to that extent. Next test was to turn off WiFi and BT on my phone and try connecting to the APC. The app failed because it needs BT turned on, which I did, then traveled outside of BT range however could not get the APC to connect over LTE. I am not sure the app or the WiFI implementation is ready for prime time… shame. If I decide I can’t live without the WiFi feature I’ll return this one, save a few $$ and get the BT only version, or try one of the other PC’s that are out there.

I should probably just try cooking something rather than pissing around with the IT stuff lol.

Sorry Anova, OOB experience 2/10 (the packaging is nice).

Thanks again guys/gals !

go ahead and pair it with your daughters phone again. as long as you use the same username/password to log in to the app, you wont need to re-pair it on your phone

@Walter_Ego, thank you, great suggestion! I tried that and still no WiFi/LTE access to the APC.

I noticed whilst reading the WiFi connection troubleshooter on the app that the WiFi password cannot have a special character, mine did. I changed that, no small task I have 37+ WiFi devices (home automation junkie). Changing the password did not resolve the issue, immediately.

I decided to remove the app from my phone and reinstall, connect to the APC and rerun the setup including the WiFi connect setup. It worked first time and turning off BT and WiFi on my phone does not sever connection to the APC. So, not sure if the root cause was the special character in the WiFi password or the 5/2.5GHz thing. Of course there is also the possibility that I over thought the whole process and just give myself a migraine for no reason.

I do think that Anova needs to rethink the WIFi setup methodology, expecting the average APC user to get into an area of WiFi configuration (2.4/ vs 5GHz) that is out of the norm is unrealistic.

Standardization on documentation also, I do not recall seeing the no WiFi password special character requirement in the mainstream FAQ’s and docs, only on the app?

WJ

glad you got it going, although seems like it would have been a pain getting there though!

which special characters do they apparently disallow?

All of them… "Make sure your WI-FI password is between 8 and 18 characters and doesn’t have any special characters:! @ # $ % ^ & * ( ) { } [ ] ", . = + ~ ` _ < > : ; | / ? \ "

Orignal document https://support.anovaculinary.com/hc/en-us/articles/205924616-Precision-Cooker-WI-FI-Connectivity-Troubleshooting?mobile_site=true

my cooker uses a wifi network that has a password way longer than 18 chars and includes several of those characters, so it may not be accurate anymore.

Interesting… and I suspect even more now that my wifi password changing project was an exercise in futility lol…

Thanks everyone for jumping and helping out @wakajazz with the the connection issue. You guys the real MVPs. Ahhh so sorry for the late reply!! Had to take care of something. :dizzy_face:

It looks like you were able to get it to connect? Anyway… the Eero WiFi Router system does work with the cooker. I believe all you need to do is disable all other access points and connect directly to the main unit, where your modem is connected to.

But let me know if this doesn’t work or if you have connection issues again. I can double check with the product team.

Does the limitation on the WiFi Password still exist as per this Precision Cooker WI-FI Connectivity Troubleshooting? I have a more secure, longer one. and this is the one device in my smarthome I’ve come across that has a character limitation.

Hey @dP21! Yes, that guide for the WiFi password still remains. Have you already tried connecting your cooker with WiFi?