First we had temp irregularities, then no impeller, now nothing at all. Very frustrated!

Back in late January, I cooked an awesome 8 lb beef roast and loved my new Anova doohickey (rec’d late January). Then, when I was using it to reheat, the temp reading started swinging wildly (from -93C to +210C) and finally settled down in the water bath at a reading of -10C. Obviously, this was not correct.

Next time I tried to use it it would not run the impeller at all until about an hour after I turned it on (the heater worked, though).

Last week, I managed to successfully cook another roast with no issues. Yum!

Today, I tried to use it again. I plugged it in, all the lights came on, and then everything went off. Unplugged it. Now when I plug it in nothing comes on at all.

Even if it would come on, now, I am not sure if I would trust it for use to cook anything (can turn off at any time).

Hopefully the service dudes can help me out. I had high hopes for this device (highly recommended by a friend) but I am now just VERY frustrated and annoyed.



Feel your pain. It’s always frustrating when a new-cool gadget disappoints so early in it’s life. It sounds like your unit has a faulty solder or loose connector. As the unit isn’t designed to be opened (as far as I can tell!) for inspection or repair by us consumers, I would propose getting a return authorization and getting it back to Anova for a fix/replace.

Because your first few cooks were relatively long affairs, there is a small outside possibility that some water vapor condensed inside the unit. It would be pretty hard as the vents are in the back of the unit and the fan keeps positive pressure while the unit is operating. If that is the case then the unit might “fix itself” if allowed to dry out for a few days. (Note that I’m not betting a lot of money on this…)

For long cooks I find it’s best to use an insulated cooler with lid (and a hole for the cooker body). Also for all cooks it’s important that the unit be clamped to the back of the cooking vessel so the ventilation holes aren’t hovering over the warm cooking water.

Thanks for the advice. I do use a cooler for all of my cooking events. After I posted to the forum, I decided to send a copy of this post to the support email (around midnight EST). Within 25 minutes or so, I had three responses from Anova, and the third one directed me to send them some info so they could send me a replacement unit. Pretty good service, I’d say. Now all I have to do is wait…

@MarkSegstro Glad to hear our support team took care of this, they’re awesome! Replacement units are usually processed pretty quickly so you shouldn’t have to wait too long. :slight_smile: