"Food is ready" message on phone despite device still having 1,5hrs cooktime

Why is this?

In the app it says FOOD IS READY.

And its not even near ready, if I’d eat it now, I would get a food poisoning.

Is the app just buggy or why is this?

Slow down there with all those details…like what you were cooking, and at what temperature, and how long the cook was supposed to be…

Could be a simple network blip or anything.

I would delete the app and reinstall. If it happens again after that grab a screenshot and send all details to support. I am on the iOS version. It works well for me.

1 Like

I’m getting this too, but it’s only in the app. On the Anova the timer is still working.

I also have had the timer just stop counting down completely on me on the app and the device.

Was working perfectly until the latest app update.


the same happens to me. Tried deleting the app and installing it again…same issue. I’m cooking steaks at 133.5 F for 8 hours. After about 15-20 minutes, I get the message “food is ready” and need to re-input cooking time. Any ideas on how to fix this?

Just happened to me again lol. IT was a 36 hour timer, told me it was ready this morning after only about 6 hours. Reset the timer on the phone, it’s telling me again it is ready now. There is still 24 hours to go. Timer on Anova is still set right, it’s something with the app obviously.

It sounds like a bug. :frowning: I will flag our team about it. Also, if you’re able, it will help to reach out to support@anovaculinary.com, so they can try to get more information regarding this issue.

So after a bunch of other disconnects this morning, I finally deleted the app, re-downloaded and re-paired (after unplugging and clearing the bluetooth by holding down the wireless icon). This seems to have solved the issue, hopefully. Knock on wood :slight_smile:

Hi @RDustinC,

I’m going to stick my nose in here with a couple suggestions that might help us help them get fixes for our problems! :slight_smile:

When developers work to fix bugs in a program it’s extremely helpful if they have step by step actions that were performed that led up to experiencing the problem. And I mean REALLY detailed. When they have these details step by step they can follow them to try to reproduce the error and maybe identify where it occurs and fix it. Sometimes its just the specific order in which actions are taken cause a bug to show up.

I know this may seem - correction - will be a pain in the rump, but it can really help when trying to resolve a bug. I’m being a little hypocritical here as I’ve not taken the time to practice what I’m preaching when I’ve run into bugs in the app - been too rushed around the Holidays. I do know that if I want these bugs fixed then taking the time to provide the extra info to the Devs at Anova should help.

That said - @RDustinC I hope you’re now problem free!

1 Like

Honestly, it’s hard to say the steps that produced the problem lol. I started the anova with the app, and then would use my phone as usual (email, facebook, web). Notification . . . Your food is ready! Um, not it’s not? LOL.

Sorry, but the app just kept telling me my food was ready. I would stop the cooking in the app, but first look at the timer left on the actual anova, restart the timer/cooking session on the app based on that number. Anywhere from 15-30 minutes later, rinse and repeat. I’d get an alert my food was ready and it would be kept warm for me.

I finally just deleted the app and reinstalled it, that seemed to work. So I’m guessing it is an issue that had to do with the app being updated and something not working right after. I know that’s happened before, and developers have put out a notice suggesting people delete and reinstall the app from scratch if they have issues.

Thanks for mentioning the delete/reinstall suggestion from the devs! I hadn’t seen that recommendation, so it’s good to know in the event I hit something.

Hello from Spain. I bought the Anova one month ago and, first of all, I have to say I’m very happy with the device and with the taste I get with all the meals I’ve cooked with it.
Some little problem to get the wifi working the right way but quickly solved with the support team help.
After that, I’ve been having this issue with the premature ‘Food is ready’ message.

I’ve just reported the problem to the support team in this terms:

“I have the wifi model. Usually I introduce temperature and time of cooking and check that my set points appear in the display. Well, almost always I receive the message ‘Food is ready’ much earlier the real time is reached. I think the problem is related with lost of connection, what necessarily happens when I go out of my house and my phone switch from wifi to 3G network. When I recover the comms the app’s timer set is lost and shows ‘:’, spite of that the Anova still shows the right time remaining. Nevertheless when I select the option ‘Set timer’ in the app, the default time shown matches the real time remaining. Then I press ‘Set Timer’ button and the app shows ‘Preheating’ for a while. Finally, the app shows the right remaining time… Until next comms failure.”

I’ve experienced the premature “food is ready” notification with the bluetooth model. The phone was never out of range of the cooker at the time, within five or six meters in the same room from when I started.


Same problem here with the Wifi model. I have also had the unit stop at one time, just keeping the same heat, even though there 28 hours left.

Unbelieveble there should be problems like this. Technology seem quit simple.

Welp it happened again today. I went to bed cooking food, woke up and my food was ready far earlier than it should have been.

I found another app that cost 3 bucks in the IOS app store and may try it and see if it has the same issues. May also try it on Android Tablet to see if the problem also exists there.

IS anyone getting this disconnects on Android? That may be another clue to where the bug is.

Yes, the disconnects exist on Android. I can’t say I’ve had early “Food is ready” notifications though.

I’ve gotten to the stage that I usually set my cooker manually and run a manual timer if I have a time critical cook. For most things I don’t use a timer.

I just purchased my anova apc and set it up last night. I connected it to WIFI as instructed and followed the other prompts in the iOS app. I set up my first cook which was 1.5hrs at 140° and then edited my time to 1:15. The timer went off after 30 min and said my food was done-it was not. I tried to restart it via the app but only got a persistent “preheating” message despite the fact that the anova was preheated already and in fact still cooking. The anova apc seemed to have the correct time remaining throughout this problem with the app. I cancelled the cook on the app and pressed the stop button on the apc. I then started a new cook via the app and the apc started back up - both in sync. After dinner, I started a roast on a 24 hr cook via the iOS app. Although it should not be ready until about 9pm tonight, the app alerted me that it was ready at 7am this morning. During both of these incidents, the iPhone 6Plus with iOS 10.3.3 and the APC were connected to the same WIFI network. The iPhone was not in use during the disconnect and I picked up the phone later to see a push notification that my food was ready.

I was and am excited to get into spud vide with the anova but this issue really concerns me. The food is not ready but the app says it is. This is a major concern for me because it could easily lead to food poisoning if one relies on the app to be accurate – as we should be able to do. I’d like some information on the status of this issue and when a resolution can be expected. Thanks very much!

Jim, if you would like to add about 10 years to your life expectancy you might do as many seasoned users are and use the Anova manually. It’s simple, totally reliable in my almost 3 years of experience. And doing that let’s me focus on enjoying life without an iPhone.

A 24-hour cook time is very forgiving with SV, particularly after 10 hours. If you are diligent about kitchen sanitation and personal hygiene when handling your raw food, you don’t need to be too concerned about a food borne illness if an interruption occurs as the water temperature declines slowly, very slowly in an insulated vessel.

If you or a family member have a compromised immune system that’s a serious matter and as you know every precaution against infection must be taken. Otherwise the human body has a rugged system to deal with common bacteria like that found in aged cheese, charcuterie, fermented foods, etc.

1 Like