Has This Happened To Anyone?

The first time I cooked with my unit, everything went fine.  The filets turned out wonderfully and I was in love with my new toy.  The second time I used my unit, it went haywire on me.  I was cooking another filet to be followed up with a lobster tail.  I set my Anova Precision Cooker to 135F.  It heated up to 135F so I dropped in the filet for a 2 1/2 hour bath.  About 1 1/2 hours into the cooking, I noticed a lot of steam coming from the Cambro container and more closely noticed that the water was starting to BOIL!!  The readout on the Anova showed 134.9F and the preferred temp readout was still 135F.  I got out my instant read thermo and it read 197F for the water bath!!!  WTF??!  So I immediately unplugged the machine while Hubby and I were discussing what to do.  Filet was totally ruined!!  So I plugged the Anova back in and the preferred temp readout still showed 135, but the actual temp readout showed 192F at this point.

I unplugged the unit again and we cooled down the water bath down to about 120F, then started the Anova up again to 135F.  It brought the water up to temp and I was constantly checking it with my instant thermo for issues.  Did the lobster tail, but dinner was an afterpoint when the filet got ruined.  

The next day I filled up the Cambro with water again and got the unit to heat up to 135F and cool down to 120F.  It seemed to work fine, but I'm still a little uneasy.  

Has this happened to anyone else out there?  Should I press Anova for a replacement for a defective unit?

BTW, I bought this from Amazon and, ironically, my second use of the unit was one day after their 30-day return window when the unit went on the fritz.

Thanks in advance for your answers.


You should delete the duplicate posting (if you can) Barbara, so you don’t duplicate effort from the community.

I wouldn’t run the gamble of the unit behaving itself.  Contact support and ask for a replacement - otherwise you’re running the risk that it’ll happen again (best not to waste your food or time) :slight_smile:

This recently happened to me also. It was like a run-away with a heater switch stuck ON. Anova display said 134 with setting I wanted at145. Instant read thermometer said 194 with a lot of steam rising.

I turned OFF (at control panel), waited a few minutes and restarted, with same result. Shut down and disconnected plug at wall. Dumped tray of ice in water to cool down. With unit somewhat cooled, I pulled out, checked to make sure there wasn't something inside. All clear. Plastic end cap which has been broken for a while was still all there. Reinstalled, came up to temp, ran fine, cooked eggs to perfection.

Planned to do 30 hour ribs but until there is a reliable solution I will have to only use outside in a "fireproof" area, just in case.

A real solution would be appreciated as I've become addicted to perfect sous vide eggs!

Contact Anova support and get an RMA and have them send you a replacement unit, as there is nothing you can do to the unit.

BTW - I had one that went batshit crazy also.  Started reading around 400 F on the display, set point was at 190F, actual water temp never got above 130-something.  Another time, I forget what target temp it was set to, but it showed -17 on the display temp, yet heated to 180,and the app showed -1760F as the “Actual temp”.  

Excellent support response! Sent in old unit and as soon as they had notice that it had shipped from me, a new replacement unit was on the way to me.

Only problem: The new replacement unit arrived. Plugged it in and unit was DOA. No display or indication that it had any power. Checked on another outlet. This time I saved packaging so was easier to return. Replacement #2 is on the way.

Still great (continuing) support response but starting to question whether there is a comparable QC effort.

Luckily I have second backup unit (from Kickstarter program).

Boy oh Boy… I guess it is not just me that this has happened to!!  ! I really like the design but the reliability for Anova is just NOT there… I have purchased two of these units and both have failed me… customer support on the first one was great… responded on a Sunday and by Monday it was shipping back… Service was so good and I really liked this unit so I purchased another one, directly from Anova. It worked for a little over a week and POOF, another temperature control problem…this time it read -32f but was 182f… hard to cook with this problem. Thankfully I purchased a Sansaire at the same time, which I’ve had NO problems with. I wish to own two working units. I wish one of them had Wifi, and I wish that it would last for many years, without any issues… Unfortunately, there is not one of these out there on the market. Maybe the Joule from ChefSteps will be the one that WORKS… As for Anova I will be the messenger and tell my experience to everyone that will listen…Thanks for listening

I’m getting this problem as well. I had it a year ago, now just had it again last weekend. Ruined my fish. My unit is out of warranty. Can Anova confirm if this is fixed in new models or not?