Heating element doesn't seem to work

I just received an Anova precision cooker, and it doesn’t heat!! I have been so excited to get it - I’m very disappointed.

I doubt that there is an at home fix for this, but I’m hoping against hope! Any suggestions?

I completely understand production scale up issues, and I am sure the anova team are working their asses off right now and it is a pretty thankless task when people (understandably) get upset that things go wrong.

I have exactly the same problem. Sorry, I don’t know of anything to do about it. Mine was a white one, which I know had a delay in production. Curious whether or not yours was too.

Mine is a black one. I’m tempted to open it up and see if the element is disconnected, but that would void the warranty.

Have the red one. Used it twice. First was for a 62.5 C egg. Worked fine. Second was for 141 F chicken breast. Worked fine but when set it to 130 F to hold after a few hours the device just stopped doing anything. Tried today to cook carrots at 90 C. was heating fine then just stopped. Not sure what to do and no support to ask.

@nycaussie‌ this sounds like a hardware issue, we’re going to want to take a look at this. Follow this link to get the return process started:


I just submitted it. I hope you can process the return approval quickly as I am leaving for Christmas vacation on Wednesday and would love to get it sent back to you before then

My heating element went out on my Anova One as well, after light use of 1-4 times per month over the last 6 months :frowning:

I’ve also submitted a return request and hope that somebody is handling these issues over the holidays because I’m hosting a tasting menu dinner club in a bit over a week and need a working unit ASAP… I really hope that Anova pulls through for me.