My cooker is not heating water

My ANOVA precision cooker has stopped heating the water it is immersed in. I bought it exactly one year ago (and a few days), that would make it just outside the warranty period. I love this device and would be devastated to lose it from my armoury of cooking instruments. It seems to be clean and have no mineral build up etc. What should I do?

I really love my Anova
Even though it can’t make Pavlova
After a year its not working
And now I am shirking
Send a new one and I’ll be in clover!


Woe is me, my ANOVA has died,
You won’t believe how hard I have cried
No more tasty sous-vide
So its back to mashed swede
I need a new one to be at my side!

The guarantee recently expired,
Just when my ANOVA cooker got tired
I hope and I pray
That I’ll see the day
When a new one will be admired!

Nice poetry. But have you actually been in touch with Anova Support at all?

That was pretty creative. :wink:

Even though your warranty has expired, i’d still contact customer support and let them know your cooker is being weird. They can help.

Thanks. Done that and nothing they suggested worked. I have sent them my order number and am waiting for a response.


Thanks Ember. I have done that and am waiting for a positive response, given everything they suggested has not brought my machine back to heat-making life.


My Anova quit heating. Still circulates water but no temp rise. happened last night. I was cooking salmon and a tuna steak and noticed that temp read 119 and I was set on 120. watched it go on down to 117. luckily my cook was done but its not a steam issue at that temp. just tried again in a pitcher of water (next day) and no heat. play/pause button shows white not red. Any suggestyions before i call support?

Fantastic! I didnt even call customer service! Shiela saw the post from cust service and emailed me with possible remedy. It didn’t fix my problem so with no hassle at all, I gave her the info she needed and Voila! I just got my shiny new unit delivered. Thank you so much Shiela even though your name should be spelled Sheila. LOL! Very happy that I’m back in business.

1 Like

Sheila please contact me as I am having the same is whybuynew had – circulates water but no heat. Just purchased in December as a Christmas gift and have only used this 4 times. Was concerned I may have overworked it by running it overnight at 140F. I did notice that it seemed to be having an issue holding the 140 right from the start. Is there a temp and time limit for these devices to be operated at? Youd think since it is AP controlled there would be safet operating limits built into the software. Let me know proper steps to resolve. Thanks.

@BBrian Sheila doesn’t monitor the forum. Have you already submitted a ticket to us at support regarding this issue? If not, please email us at

1 Like