New android app update

Anyone else has their temp changing randomly on its own after the new android update? I set my temp to 140f and it keeps changing on its own. It was 135f 131f and other random temps. It worked perfectly before the recent update from the play store.

I woke up this morning with an updated app, and wanted to cook eggs. But unfortunately now I can’t even connect to my anova. It goes all crazy as if it can’t connect… It connects, then disconnects, then connects, then disconnects… All within seconds… And it just continues like that.

So I’ve downloaded the old version of the app again, from a 3rd party website, to make it work.

Bugfix release… Yeah… With a few extra bugs I guess :slight_smile:
Wonder what their test process is? Are there actually professional developers involved in this?? The app sucks, has done forever, and when you tell them, they don’t really seem to care. No new features after months without an update… Just “bugfixes”… Introducing new bugs!


They don’t even want to bother themselves with an open API so real developers can make something that actually works…

Mines did the exact same thing. I finally got it to unpair and it worked but the temp started to do it own thing. The app worked perfectly fine before this last update too.hope it gets fixed soon as I liked that I can control it from work

It kept connecting and disconnecting nonstop also till I finally got it to unpair.

It’s still possible to use bluetooth but you can only use wi-fi now if you have Amazon Alexa or Google Home (and have one of their devices)… I don’t know of a workaround. If so, this is pretty shabby treatment by Amazon. I don’t intend to buy either Amazon or Google devices just to have the full functionality of my Anova that I’ve already paid for. So, my next sous vide device won’t be an Anova, and Amazon have just lost a customer. It was good while it lasted…

I don’t understand. Are you saying that you can only use your APC’s Wi-Fi connectivity with an Echo/Google Home, and not with the phone/tablet that’s running the mobile app? And what exactly is it that Amazon did?

It appears the updated app will only pair through wifi if you provide a Home/Echo account. To create an account you have to have a Home/Echo device. I’d welcome a workaround or comment from Anova developers. I think I hear the distant sound of lawyers rubbing their hands at the lucrative prospect of a class action lawsuit.

@Derrick_Leigh, your comment is confusing and not accurate if I am understanding it correctly. Your Wi-Fi cooker should be able to connect with the app without providing a Home/Echo account. Additionally, your APC should be fully working without the need of Google Home or Alexa. If it’s not, you need to reach out to customer support, since that’s not an expected behavior for the APC or app.

To all that are having issues with the new app: I will ping my team. But if you can create tickets with support with additional info regarding the issue - that’ll also be super helpful for us.

Even if that’s true, why are you blaming Amazon?

Based on what tort, exactly?

There has been a further Android update resolving this issue. I uninstalled and re-installed the latest version. There is an option during setup to use wi-fi without an Alexa/Home account and it works. Thanks for your patience and a speedy fix.

The new app for the Anova is horrendous, I’ve sent several messages to thier software development team…I want the old app back, it worked better and was very reliable…

the connection process is horrendous. screen won’t scroll. have deleted and reinstalled the app several times. getting very annoying when all I want to do is some eggs. the app set up is taking longer than the cook time. should have just uber’d some breakfast this morning, would have been quicker.

quite disappointing.