Precision Cooker 120v - tech issues

I have an Anova Precision Cooker 120v unit. It worked great for a tenderloin on Christmas Eve but then stopped working when I tried to use it for New Years Eve. The unit still circulates but doesn’t heat the water - the black rubber part just below the temp reader gets hot but the metal part below where the circulator is stays cool. Its very possible its user-error. Any suggestions? I tried calling the anova support # and got dumped into a mailbox to leave a message. Thanks in Advance!

The only way it could be user error would be if you set the temperature of the Anova to room temperature. :slight_smile:

Obviously it worked once and now isn’t - pretty indicative of a defective unit. If I were you I’d either leave them that voicemail or send an e-mail to
(thinking the e-mail option may be the best use of your time) - give them a couple days to get back to you.

1 Like

Seconding what @fischersd said! email and we can get you set up with a functioning unit. :slight_smile:

Thanks! I sent An email just prior to posting my question in the forum. I will wait to hear back.

1 Like