Problem / long lasting beep on my Anova

I advise reaching out to support@anovaculinary.com if your cooker is screaming at you for no reason.

Same problem here. Just unboxed my Anova. It keeps beeping no matter what I try to do. Tried to unplug it many times, nothing changed.

When you plugged it in, was it in a water bath?

Me too. Just unboxed this. Put it in a room temp water bath, with an appropriate amount of water. Turned it on and got the beep of death. Also bought another as a gift for a family friend. Now not sure if I should give it to them as I don’t know if it will work or not.

I just got this out of the box. Tried everything everyone mentioned here with no luck.just always beeps. Do I have to go through the whole return process and freeze these steaks I just vacuum sealed? Horrible.

I would definitely go through customer support. We may be able to actually just troubleshoot the issue for you.

All your forums say the same. „Support can help - probably“

  1. i see this issue exactly the same for posts 2016 to today and never a direct answer.
  2. why not just post the solution if there is one or admit that an exchange is necessary.

Just unpacked mine - exact same result. Super frustrating.

The cooker gives off notifications for different reasons, but if the alarms/notifications aren’t working properly as they should, you need to reach out to support so they find out the exact issue. Help is at support@anovaculinary.com. I recommend taking a look at this help desk article as well. :slight_smile: :wink:

I just unpacked My Precision cooker Wifi. Connected it to wifi. The app can see the temperature. Put it in water, and the level is at maximum. My device wont stop beeping. It just continues. It’s brand new unpacked, cant be any moister in the head of the device. Any suggestion other than send it back?

Uninstall the app and try the unit manually to see which is causing the problem. If the unit runs fine without the app complain to support about the app. If the unit is still beeping when controlled manually complain to support about the unit.

I just got this out of the box. Tried everything everyone mentioned here with no luck.just always beeps. I already contact support but still waiting for a reply.

I wanna cry.

Permanent fix

Having the same issue. This unit just arrived from Anova directly, it is a replacement unit for one that lost it’s temperature control, ran hot.

The new one arrived today, uninstalled app, reinstalled app, connected received 3 beep confirmation. Set temp and timer in app to cook some new york steaks. Hit START and long unstopping beep. Water is well past minimum. Unfortunately it is Friday night and no support is available.

Hi @TheGrind

Stick to working with Anova Support until you have no absolutely no other option. I really appreciate the information @BobRoss has provided, but keep in mind that it is a “last ditch” option!

And thank you for providing it @BobRoss !!!

1 Like

Brand new today, water level perfect, try to start and non stop beep, what do i do? turned off and on etc.

Contact Anova support at support@anovaculinary.com

Just opened my anova precision cooker and I am having exactly the same problem as other posters here. Like other posters here I have tried everything mentioned here and nothing has worked. It seems that there is obviously a fairy batch that anova is still sending out to customers despite knowing that they have a faulty batch. Definitely should have gone with another brand.

Have you seen my guide?

Another frustrated user of this Precision Cooker 4.0. Looks like a lot of us are having the continuous beeping issue right out of the box. I just contacted support and I hope they can give me a replacement that does work. Its gonna be difficult for me to get it since I already left the country (Australia) that I bought it from so postage fees are gonna be costly. Such a pity as I also have the Nano and that worked like a charm till today.

Might just try BobRoss’s guide if they can’t help me out.

Anyone know the remedy to this problem. Some of the strangest sounds on the souse vide??