Problem / long lasting beep on my Anova

HI Everyone , I have recently had a problem with my Anova, it won t stop beeping not due to the lack of water. Coud you please tell me if there is a solution to this problem.

I only bought 2 years ago straight from Anova website.

If no solution propose i might have to go with another brand

Looking forward to hearing from you

Many thanks for your future answer

Hi Fabian,

I’m so sorry you are having issues with the device.

You may want to try restarting your device by unplugging it and plugging it back in.

If the problem continues, send me a message and I will see what I can do to help you out!

Kindly,
-Hunter

Hi Hunter

Thanks Hunter for quick reply

I did unplug it and plug it back but without any success.
I have tried day after and it was same outcome but today for some reason leave it plug for 20 min, that was fine

I have attached a video that i found on you tube that describe my problem

I will keep you posted if i have any further issues.

Regards

Fabien

I’m glad it is working!

Thanks for attaching the video. I will let you know if I can find anything that is causing the problem.

Let me know if it happens again, and I’ll do my best to help you out!

Thanks Hunter,

For sure i will do as i love Anova product and i always try to promote your products around my guests and chefs in New Zealand.
So hope it will work fine from now on !!

Regards
Fabien
www.myprivatechef.co.nz

Hi HunterC,

I got the same problems here, however I have just received it on this week.
I haven’t cooked anything since received. The same problems come into these 3 days and I have unplugged it for uncountable times. Why???

What are you support team and QC doing? Anova made me crazy!! I need to self-help myself to solve the problems on the community during the Thanksgiving day!! The community and Avona website helped nothings!!

I would like to have an early reply or refund on Monday!

Regards,
CYT

Hi CYT,

I’m so sorry this happened for you on Thanksgiving! We can definitely get you set up with a return or an exchange, fill out this form: https://anovaculinary.com/pages/returns/

I cannot guarantee that the entire process will be complete by Monday as since it was just Black Friday our Support team is working hard and doing our very best to answer all the questions we have been getting as a result.

I want to make sure you get everything figured out though, so please it by Tuesday you have not received an email back let me know, and I will see what I can do.

My apologies once again, I’ll do everything I can to get you cooking asap!

Hello Hunter,

I bought an Anova 1 month ago and have used it one time only. Today I wanted to use it for 2nd time and I am experiencing similar issues than the video atached in this post. I plug it in, press the start button, and the device starts beeping without end. I tried plugging it in, out, several times… Does not work!

How can this happen with a new device? What kind of confidence can I have if I ask for a replacement? I have read different posts and this problem seems to be widely extended, so not sure whether asking for a replacement or a refund to go for a different sous vide product.

Thank you,
Pablo

Hi @Pablo, so sorry you are experiencing issues. We have a money back 60-day guarantee and a 1-year warranty, so we can definitely get you set up with a new unit. Please contact support@anovaculinary.com and we will help you out!

@HunterC Hi Hunter
I got a similar problem. I received the unit in December and used it twice to get excellent results. On the third use, the machine broke down. There was the long continuous beeping despite of high water, then the current temperature reading started to fluctuate, first by a few degrees and then by a few hundreds. How can I get a replacement ( preference) or return for refund?

Thanks

Hi @BrianG, please contact support@anovaculinary.com and we will get you all sorted out!

@HunterC I already contacted the support and provided all requested information but did not receive an response for 2 days. Can you help or should I just file a chargeback?

@BrianG, I can look into it, are you trying to return your device? I will let the team know you haven’t received a response so they will be getting back to you soon!

@HunterC, Thanks. While the person responding to the support email failed to follow up, I was able to reach a person via phone and he will arrange to send a replacement.

1 Like

Hello. I bought my Anova Culinary one month ago and I have used it 5 times with great results. Today during preheating it started beeping and it did not stop until I unplugged the device. I have tried several times during hours with the same result. It is not a problem with the level of water.
I have seen in this Community that it is not an unusual problem. Have you find out a solution for this problem already? Could you tell me something about this or should I return the machine?
Thanks!!

1 Like

@Sonia1 this article on the site is super helpful - you might be able to pinpoint the issue: https://support.anovaculinary.com/hc/en-us/articles/204567894-Different-Beeping-Noises-and-What-They-Mean

But if the beeping persists, I’d suggest reaching out to support@anovaculinary.com so they can take a look at what’s going on with your device! :slight_smile:

1 Like

Hello, the day after the problem I was able to solve it. Some steam went in and I could not use the device until it dryed. It is working perfect and I just need more practise with the machine.
I’m really happy with this machine!!

Yes! I am glad to hear it’s working now! What have you been cooking with your Anova?

Folks, here is the way you get your Anova working once its had this problem, and a way to prevent it from happening again. The issue I’m addressing is when the beeping happens and you receive an alert that the water is too low when in fact it’s not.

  1. Once the device starts beeping repeatedly, unplug it immediately. Observe that the head unit has been in a particularly steamy part of the pot, and the sensors are being overwhelmed with humidity.
  2. Remove the device entirely from the water, allowing as much of the water to pour out of the anova as possible.
  3. The metal cover will be very, very hot. Holding the head of the unit in your left hand and use a potholder or otherwise heat-resistant glove, remove the metal shaft by twisting it counter-clockwise. It shouldn’t resist much, and should easily open up. You’ll see the heating coils exposed.
  4. Place the unit on its side on a heat resistant surface (granite or stainless steel counter, stovetop) to cool down. Leave it for ten minutes. When you come back to it, it should be room temperature again, and there should be no remaining liquid. (Take this time to wipe off the metal parts with a dry paper towel and make sure there is nothing trapped among the coils.)
  5. Put the unit back together (align the metal shaft with the head unit and twist clockwise until it locks), then put the unit back in the liquid, re-fastening it to your container. Plug it back in and allow the unit to re-heat the water.
  6. As the unit starts re-heating the water, cover the container with saran wrap in a way that prevents steam from reaching the head unit, being careful not to submerge the wrap in the water, and preventing the wrap from touching the hot metal surface of the unit. The idea is that that the steam won’t be able to escape the pot and most especially not flow into the unit.

Since doing this myself, I have had no issue, but it may not be a lasting solution. I’ll report back if I have further issues.

Yes, this may help. I find it quite amazing that a device that, by design, is meant to be very close to hot water (hot water that is produced by the device itself), was designed in such a way that it fails when it is close to hot water.

I wonder what Steve Jobs would have had to say about an iPhone that fails every time it tries to make a phone call to someone else because it can’t handle all the electromagnetic radiation that it produces…

Michi.

1 Like